Does anyone know how to allow internet to my nodes from the rack controller? I have a pfsense router, then rack/region controller with 2 nics (0=wan, 1=lan(for dhcp pxe nodes)). Nodes will pxe but miss steps during juju controller bootstrap because of lack of internet connection. I have also added another network to all the nodes and pfsense, adding static ip's in the arp table for every node, this was hit and miss. I also tried 2 nics for each node, also hit and miss when it comes to juju because the private pxe network has no internet. I've been all over the internet and it seems netplan doesn't care what the hell I put in the cloud-init file it's going to do something else. I'm starting to think a MAAS deployment with juju is not a time saver, rather a soul drain.

I've tried all sorts of things for a week now, 14 hrs a day, I'm about done with this. I managed to get a juju cloud sort of up 3 times out of 1500 installs, there is no rhyme or reason as to why it works sometimes. The documentation is misleading and leaves out important steps.

  • Still working on this.Went back to 18.04 and tried this:askubuntu.com/questions/1050816/ubuntu-18-04-as-a-router – beef Oct 26 at 19:11
  • Still working on this.Went back to 18.04 and tried this:askubuntu.com/questions/1050816/ubuntu-18-04-as-a-router I am still not able to get a juju controller to bootstrap without dicking around, like rebooting the rack controller after the install hangs. I changed the IP listed in regiond.conf to match the correct address, running the other command completely destroys the entire setup. I also made allow all rules for the ufw, and got rid of ipv6. I keep getting the error " Node post-installation failure cloudinit". I thougt this was a missing "if" in – beef Oct 26 at 19:21
  • cloud-init.conf, I added the "If" and it seemed to just hang without the error, but on new reinstall dosn't matterr. DNS is also acting funny, not catching all the machines, nothing with this is consistent, i can reboot machines and they do something new each time, goddamn bullshit. – beef Oct 26 at 19:24

!/usr/bin/python3

EASY-INSTALL-ENTRY-SCRIPT: 'cloud-init==18.3','console_scripts','cloud-init'

requires = 'cloud-init==18.3' import re import sys from pkg_resources import load_entry_point

if name == 'main': sys.argv[0] = re.sub(r'(-script.pyw?|.exe)?$', '', sys.argv[0]) sys.exit( load_entry_point('cloud-init==18.3', 'console_scripts', 'cloud-init')() )

  • i don't know what the fuck is wrong with this but it won't let me paste the code. I'm ready to go take bill gate's billion dollar dick it the ass and say fuck ubuntu – beef Oct 26 at 19:31

Just a follow up:

Currently have this working (Juju kubernetes cluster on MAAS). I was not able to get packet forwarding to work properly or allow internet to pass through the rack/region controller. Some parts work work sometimes but not other times, during this process I tried all different networking configurations and this was not without collateral damage. Anything that was a ubuntu machine, unrelated to the cluster, got their DNS scrambled and I cannot get them to function on the local network for shared mounts, I get an unknown error in name resolution. Somewhere along the line MAAS brought these machines into it's domain, this is no longer the case but I still haven't figured out how to fix it. If anyone knows whats going on here any advice, besides reinstalling, would be helpful.

To get this working I had to use a rack/region controller, on 18.10, no extra packages at the time of install. I disconnected all but one physical network interface from every server and used a physical interface from pfsense, to a unique switch on it's own domain. The pfsense has DHCP enabled, can't get it working without it on, and so dose the rack/region. I created a reserved range in the dhcp space for both, non-overlapping. Rack/region has a static assignment in pfsense, TFTP server is named (RACK/REGION IP), and domain is named in pfsense. I had some trouble initially getting PXE to work after pfsense assigned an address, I'm not sure if enabling and disabling ignore BOOTP had any effect or if it was uninstalling the TFTP server package from Pfsense but it definitely didn't just work. Pfsense assigned the first IPs and would not forward them to the rack/region.

I'm still not pleased with this setup, the networking does not seem to make much sense, not that pfsense is any better. I'm not sure what exactly can be done here other than finding a detailed description of lower level networking. I would like a better path to network isolation for this type of setup, using only one nic seemed to be the key but that is not how I gathered it from documentation. One NIC on the MAAS controller I definitely did not see mentioned anywhere but this seemed to be the key. I'll keep this open until I figure out what fuckery happened to the rest of the network.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.