0

Try to launch sudo apt install debsig-verify (this is needed to install slack) and get this message:

 You might want to run 'apt --fix-broken install' to correct these. The
 following packages have unmet dependencies:  libreadline-dev:i386 :
 Depends: libreadline7:i386 (= 7.0-3) but 7.0-0ubuntu2 is to be
 installed
 Depends: libtinfo-dev:i386 but it is not going to be installed  libreadline7 : Breaks: libreadline7:i386 (!= 7.0-3)
 but 7.0-0ubuntu2 is to be installed  libreadline7:i386 : Breaks:
 libreadline7 (!= 7.0-0ubuntu2) but 7.0-3 is to be installed`

OK. try sudo apt --fix-broken install and get

The following additional packages will be installed:
 libreadline7:i386
The following packages will be upgraded:
  libreadline7:i386
1 upgraded, 0 newly installed, 0 to remove and 25 not upgraded.
4 not fully installed or removed.
Need to get 0 B/128 kB of archives.
After this operation, 8 192 B of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 271028 files and directories currently installed.)
Preparing to unpack .../libreadline7_7.0-3_i386.deb ...
Unpacking libreadline7:i386 (7.0-3) over (7.0-0ubuntu2) ...
dpkg: error processing archive /var/cache/apt/archives>/libreadline7_7.0-3_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libreadline7/changelog.Debian.gz', which is different from other instances of package libreadline7:i386
Errors were encountered while processing:
 /var/cache/apt/archives/libreadline7_7.0-3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)`

dpkg -S readline.h gives that

octave-doc: /usr/share/doc/octave/octave.html/Customizing-readline.html
nodejs: /usr/share/doc/nodejs/api/readline.html
libreadline-dev:amd64, libreadline-dev:i386: /usr/include/readline/readline.h

Also dpkg -l | grep readline listing

ii  libreadline-dev:amd64                             7.0-3                                                      amd64        GNU readline and history libraries, development files
iU  libreadline-dev:i386                              7.0-3                                                      i386         GNU readline and history libraries, development files
iF  libreadline7:amd64                                7.0-3                                                      amd64        GNU readline and history libraries, run-time libraries
iU  libreadline7:i386                                 7.0-0ubuntu2                                               i386         GNU readline and history libraries, run-time libraries
ii  readline-common                                   7.0-3                                                      all          GNU readline and history libraries, common files

whats going wrong? I will be grateful for response
Add add apt-cache policy libreadline7:i386
libreadline7:i386: Installed: 7.0-0ubuntu2 Candidate: 7.0-3 Version table: 7.0-3 500 500 http://ua.archive.ubuntu.com/ubuntu bionic/main i386 Packages *** 7.0-0ubuntu2 100 100 /var/lib/dpkg/status
i use 18.04 since i updated from previous version. may be that's why added something not for 18.04 Bionic
running sudo apt-get remove libreadline7 -a=i386 cause
E: Command line option 'a' [from -a=:i386] is not understood in combination with the other options
if i try run sudo apt-get remove libreadline7 i get this: https://pastebin.com/AUmqPyT2
if try sudo apt-get remove readline7:i386 get

 You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
libreadline-dev:i386 : Depends: libreadline7:i386 (= 7.0-3) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution) 

Also got another error depends on readline. post it here?

  • Thanks. I try to follow tthat steps but after apt upgrade get: The following packages have unmet dependencies: libreadline-dev:i386 : Depends: libreadline7:i386 (= 7.0-3) but 7.0-0ubuntu2 is installed libreadline7 : Breaks: libreadline7:i386 (!= 7.0-3) but 7.0-0ubuntu2 is installed libreadline7:i386 : Breaks: libreadline7 (!= 7.0-0ubuntu2) but 7.0-3 is installed E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution). Sorry for this wall of text.I have not understood formatting here yet – BorisNepokrytyi Oct 26 '18 at 9:47
  • i install it as apt install libreadline or using dpkg. I didn't compile it from source code – BorisNepokrytyi Oct 26 '18 at 10:35
  • 1
    You install PPA sourced files using apt install or dpkg. If installed as you said, it'll likely be found in your logs. Have you added PPA's to your sources? Can you add apt-cache policy libreadline7:i386 (please add additional info to your question/post; as it can be edited & has better formatting). You've added something not for 18.04 Bionic - as the error shows something needing an 'artful' (17.10) package (hence your error - packages.ubuntu.com/search?keywords=libreadline7) – guiverc Oct 26 '18 at 10:43
  • And actually this has nothing to do with debsig-verify – Alvin Liang Oct 26 '18 at 11:13
0

Remove libreadline7:i386 which is causing an unmet dependencies error. Uninstalling libreadline7:i386 will also solve the trying to overwrite error. Then install the Slack snap package which as a standalone package will not make any additional package management problems or require any additional dependency packages.

sudo apt --fix-broken install  
sudo apt remove libreadline-dev:i386 libreadline7:i386  

IMG:  Slack is a native snap package in Ubuntu 18.10. To install Slack in all currently supported versions of Ubuntu open the terminal and type:

sudo snap install slack --classic  

This command will install Slack 3.3.3, and it will also be updated automatically if an update is available.

To start Slack click on its icon in the Dash or run this command from the terminal:

snap run slack  

Slack has a free version for small teams, or anyone who wants to try Slack for an unlimited period of time.

  • I updated post to respond your offer – BorisNepokrytyi Oct 27 '18 at 7:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.