I'm trying to disable wake-on-mouse from suspend and not having much success. As an alternative I attempted to increase the pointerhysteresis variable in the Xscreensaver configuration file as others suggested. However, no matter what I set it to it does not appear to make a differenence - the screensaver is still very sensitive to mouse movement and will wake at the tiniest poke.
Does anybody know why this might not be working?

  • 2
    Possible duplicate of Mouse movement wakes computer from suspend how to disable this? – kenn Oct 26 at 9:00
  • Not a duplicate. I'm specifically asking about what can be done to troubleshoot the fact that the pointerhysteresis parameter within the Xscreensaver configuration file doesn't appear to be being read. I have already read the thread that you linked and successfully implemented it to ignore USB inputs during the suspend state. – Daniel R Oct 27 at 18:06
  • I have two mice, one of them is wireless. While the cabled one is irresponsive of mouse move during sleep, the wireless one wakes up the computer by a single pixel motion. I still don't know what the difference is, but I don't think it has something to do with pointerHysteresis value. – kenn Oct 27 at 18:22
  • Interesting. Thanks. Since I was able to successfully disable wake from USB movements, the suspend solution is fine for me. It would be nice if I could also get xscreensaver to work as I wanted to so that I could lock the screen and come back to it when I'm only away from my desk momentarily, but what I have now is a lot better than what I did before. – Daniel R Oct 31 at 10:54

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.