0

I was using an earlier version of Ubuntu on a Lenovo laptop and a Wi-Fi connection with the VIA VPN. After accepting an upgrade to 18.04 LTS, VIA VPN fails to run. Its icon shows up on desktop but its application will not start.

When this happened on my desktop, I uninstalled and reinstalled, using a script I have since lost, which solved the problem.

VIA VPN support suggested:

rm -rf ~/.pia_manager/

If the command is successful, there will be no confirmation, it will simply go to a new line in the Terminal window. Once you have done that, you can install the app from: privateinternetaccess.com/installer/download_installer_linux, Then, from the terminal in the directory you downloaded to:

  1. Extract file:

    tar -xzf pia-v79-installer-linux.tar.gz 
    
  2. Tell OS to proceed:

    chmod +x pia-v79-installer-linux.sh 
    
  3. Run installer:

    ./pia-v79-installer-linux.sh
    

However on completion of the above steps I get the message:

Private Internet Access is already running. Please quit it and run the installer again.

  • A great question for VIA VPN support...which we are not. Sorry. – user535733 Oct 28 '18 at 13:50
  • Well Ubuntu is not allowing me internet access through WiFi. SYS does not show PIA running. – tomorrow2015 Oct 28 '18 at 23:09
  • Are you saying that on one computer you upgraded (from what?) to 18.04 and then uninstalled and reinstalled VIA VPN ? What steps did you take to uninstall? When you say it isn't "compatible" what do you mean? When it works, what steps would you normally take to run it and what would you expect to happen? Have you tried restarting your computer, and then following the support steps before you do anything else? – Amanda Oct 30 '18 at 21:24
  • I recommend reading askubuntu.com/help/how-to-ask -- there's just not enough information here for anyone to help you. – Amanda Oct 30 '18 at 21:27
  • The VIA VPN Private Internet Access processes should be stopped before deleting and reinstalling it. Please ask their support folks to help you find those processes so you can halt them in a terminal window with sudo kill -9 nnnn nnnn nnnn where nnnn represents one or more process ID numbers. – K7AAY Oct 31 '18 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.