What must I do to type in Japanese?

I wish to use fcitx-mozc as Wakisaka recommends, but when I add 'Keyboard - Japanese' via Preferences > Fcitx Configuration, I get only a qwerty layout with Roman letter output, no Japanese formed by typing a Japanese word like 'sore'.

When I uncheck 'Only Show Current Language' and search 'Moz', there is no Mozc option.

In 'Keyboard and Mouse' via Start search > Keyboard Layout, I have "Keyboard model: Dell Latitude laptop" because this laptop is a Dell Latitude D620. I have tried adding the Keyboard layout: Japanese there, too, with Super+Space to switch, but still no Japanese output. The 'kana' variant does let me type katakana from each key, but I need to be typing in qwerty or dvorak converting hiragana to kanji or katakana.

I wonder if I have found a hint: An 18.04 user was told to edit /usr/share/ibus/component/mozc.xml, but my folder lacks this file.

Edit: I have now installed fcitx-mozc.

$ sudo apt install fcitx-mozc
[sudo] password for username: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libprotobuf10 libzinnia0v5 mozc-data mozc-server mozc-utils-gui tegaki-zinnia-japanese
Suggested packages:
  ibus-qt5
The following NEW packages will be installed:
  fcitx-mozc libprotobuf10 libzinnia0v5 mozc-data mozc-server mozc-utils-gui tegaki-zinnia-japanese
0 upgraded, 7 newly installed, 0 to remove and 1 not upgraded.
Need to get 30.9 MB of archives.
After this operation, 53.5 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://us.archive.ubuntu.com/ubuntu cosmic/main i386 libprotobuf10 i386 3.0.0-9.1ubuntu3 [738 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu cosmic/main i386 mozc-server i386 2.23.2815.102+dfsg-2 [11.9 MB]
Get:3 http://us.archive.ubuntu.com/ubuntu cosmic/main i386 mozc-data all 2.23.2815.102+dfsg-2 [11.1 kB]                                                    
Get:4 http://us.archive.ubuntu.com/ubuntu cosmic/main i386 tegaki-zinnia-japanese all 0.3-1 [17.3 MB]                                                      
Get:5 http://us.archive.ubuntu.com/ubuntu cosmic/universe i386 fcitx-mozc i386 2.23.2815.102+dfsg-2 [258 kB]                                               
Get:6 http://us.archive.ubuntu.com/ubuntu cosmic/main i386 libzinnia0v5 i386 0.06-3ubuntu1 [63.3 kB]                                                       
Get:7 http://us.archive.ubuntu.com/ubuntu cosmic/main i386 mozc-utils-gui i386 2.23.2815.102+dfsg-2 [737 kB]                                               
Fetched 30.9 MB in 14s (2,178 kB/s)                                                                                                                        
Selecting previously unselected package libprotobuf10:i386.
(Reading database ... 242486 files and directories currently installed.)
Preparing to unpack .../0-libprotobuf10_3.0.0-9.1ubuntu3_i386.deb ...
Unpacking libprotobuf10:i386 (3.0.0-9.1ubuntu3) ...
Selecting previously unselected package mozc-server.
Preparing to unpack .../1-mozc-server_2.23.2815.102+dfsg-2_i386.deb ...
Unpacking mozc-server (2.23.2815.102+dfsg-2) ...
Selecting previously unselected package mozc-data.
Preparing to unpack .../2-mozc-data_2.23.2815.102+dfsg-2_all.deb ...
Unpacking mozc-data (2.23.2815.102+dfsg-2) ...
Selecting previously unselected package tegaki-zinnia-japanese.
Preparing to unpack .../3-tegaki-zinnia-japanese_0.3-1_all.deb ...
Unpacking tegaki-zinnia-japanese (0.3-1) ...
Selecting previously unselected package fcitx-mozc:i386.
Preparing to unpack .../4-fcitx-mozc_2.23.2815.102+dfsg-2_i386.deb ...
Unpacking fcitx-mozc:i386 (2.23.2815.102+dfsg-2) ...
Selecting previously unselected package libzinnia0v5.
Preparing to unpack .../5-libzinnia0v5_0.06-3ubuntu1_i386.deb ...
Unpacking libzinnia0v5 (0.06-3ubuntu1) ...
Selecting previously unselected package mozc-utils-gui.
Preparing to unpack .../6-mozc-utils-gui_2.23.2815.102+dfsg-2_i386.deb ...
Unpacking mozc-utils-gui (2.23.2815.102+dfsg-2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-3ubuntu2) ...
Setting up mozc-data (2.23.2815.102+dfsg-2) ...
Setting up libzinnia0v5 (0.06-3ubuntu1) ...
Setting up tegaki-zinnia-japanese (0.3-1) ...
Setting up libprotobuf10:i386 (3.0.0-9.1ubuntu3) ...
Setting up mozc-utils-gui (2.23.2815.102+dfsg-2) ...
Processing triggers for libc-bin (2.28-0ubuntu1) ...
Setting up mozc-server (2.23.2815.102+dfsg-2) ...
Setting up fcitx-mozc:i386 (2.23.2815.102+dfsg-2) ...

Edit: I was able to get it working with this guide.

(This answer from three years ago appears to have the solution I wound up implementing as described in my answer below, though I think fcitx is already installed in Lubuntu 18.10.)

up vote 0 down vote accepted

The solution appears to have been simply following this guide, though I skipped the ppa commands. I recall executing the following commands while working through that guide:

sudo apt-get update
sudo apt install fcitx-mozc
sudo apt install qt4-qtconfig
qt4-qtconfig
im-config

Particularly, after running im-config as instructed, selecting fcitx, and then restarting, it is now working. I am not sure if the qt4-qtconfig business is necessary, because I was not able to get it working until I did im-config+restart through clicking the start menu entry (though I don't know if the restart is necessary).

  • A GUI way would have been to install the Japanese language from the Language Support tool. That would have given you fcitx-mozc as well as qt4-qtconfig. Language Support also has a setting to switch to Fcitx. – Gunnar Hjalmarsson Oct 26 at 13:34

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.