0

I just buy a new USB 3.0 Gigabit Ethernet Adapter and I can't install it in Ubuntu 18.04.1 server x64 edition.

I contact tp-link support and they send me the driver. I install the driver but my adapter is still without Internet connection. I follow this steps too and without any success.

Anyone can help me to fix this issue?

EDIT:

Output of `ifconfig`

enp19s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 78:2b:cb:e9:d5:3c  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enx503eaa8b183c: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 50:3e:aa:8b:18:3c  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 226  bytes 15022 (15.0 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 226  bytes 15022 (15.0 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp18s0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 18:f4:6a:3f:af:11  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Output for sudo lshw -c network

 *-network DISABLED
       description: Wireless interface
       product: AR9285 Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:12:00.0
       logical name: wlp18s0
       version: 01
       serial: 18:f4:6a:3f:af:11
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=4.15.0-38-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:17 memory:fbc00000-fbc0ffff
  *-network
       description: Ethernet interface
       product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:13:00.0
       logical name: enp19s0
       version: 02
       serial: 78:2b:cb:e9:d5:3c
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:18 ioport:e000(size=256) memory:d0b10000-d0b10fff memory:d0b00000-d0b0ffff memory:fb200000-fb21ffff
  *-network DISABLED
       description: Ethernet interface
       physical id: 2
       logical name: enx503eaa8b183c
       serial: 50:3e:aa:8b:18:3c
       size: 100Mbit/s
       capacity: 1Gbit/s
       capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8152 driverversion=v1.09.9 duplex=full link=no multicast=yes port=MII speed=100Mbit/s

The name of the file that is in the /etc/netplan/01-netcfg.yaml

CONTENT of /etc/netplan/01-netcfg.yaml

  # This file describes the network interfaces available on your system
    # For more information, see netplan(5).
    network:
      version: 2
      renderer: networkd
      ethernets:
        enp19s0:
          dhcp4: yes

Thank you in advance.

  • thank you but is not help me so much, I already try that too without any success – Robert Oct 25 '18 at 17:37
  • That should have installed the correct driver and typically the Ethernet would just work after a reboot. I can't give you further help because I'm not used to Server editions which I believe are command line only. But surely there are commands for checking if the correct network device is there and others for checking the correct network settings. From your question it's not clear whether the device is recognized but can't connect to internet or not recognized at all. – GabrielaGarcia Oct 25 '18 at 17:42
  • Indeed there is command line and this is what I need, some help on how I can check what error is there or what is the issue, I check everything and try almost everything on internet and I don;t find anything to work. for that I come and ask here – Robert Oct 25 '18 at 17:45
  • I suggest editing the question with, at least, the results of ifconfig. That will give some information about the networks devices, IP (if any), subnet, etc. – GabrielaGarcia Oct 25 '18 at 17:50
2

Try this...

In terminal...

cd /etc/netplan                       # change directory

sudo cp 01-netcfg.yaml 01-netcfg.HOLD # backup the file

sudo pico 01-netcfg.yaml              # edit the file

replace what you see there with this...

Note: if you copy/paste this text, remove the 4 spaces at the beginning of each line...

 # This file describes the network interfaces available on your system
    # For more information, see netplan(5).
    network:
      version: 2
      renderer: networkd
      ethernets:
        enp19s0:
          dhcp4: yes
          optional: true
        enx503eaa8b183c:
          dhcp4: yes
          optional: true

then...

sudo netplan --debug generate # generate the config files

sudo netplan apply            # apply the new configuration

reboot                        # reboot the system

review the previous lshw and ifconfig commands to check operation.

  • I have an error there when I use this sudo netplan --debug generate - Error in network definition //etc/netplan.yaml line 3 column 2: Unknown key enx503eaa8b183c for @heynnema – Robert Oct 25 '18 at 19:06
  • and in ifconfig is appear – Robert Oct 25 '18 at 19:10
  • 1
    @Robert Your filename doesn't look like it should... //etc/netplan.yaml. Is that just a typo? Anyway, when I formatted the replacement text so it would be readable, it adds 4 spaces to the front of each line, and netplan is very fussy about this. Either remove the extra 4 spaces, and make sure that each indent is only two spaces, as actually shown. Show me the output of the generate command after you re-edit. I also didn't understand your ifconfig comment. Report back to "@heynnema". – heynnema Oct 25 '18 at 19:40
  • you really save my live :), indeed is work perfect now. Thank you very very much you have a from me. I delete that file and I get with copy and paste the content of the 01-netcfg.yaml then netplan apply, reboot and everything is working perfect, you're the Master :) , thank you again for your help – Robert Oct 25 '18 at 19:56
  • @Robert so glad that it worked for you! – heynnema Oct 25 '18 at 20:30
0

I had a similar issue and got the card working by doing this:

sudo ip l s dev enx503eaa8b183c up
0

On 18.04.3 here, with a TP-Link TG-3468. I had to do the following:

sudo ip l s dev enp6s0 up

Then I modified /etc/netplan/01-network-manager-all.yaml to look like this:

network:
  version: 2
  renderer: NetworkManager
  ethernets:
    enp6s0:
      match:
        macaddress: "12:34:56:78:90:12"
      set-name: enp6s0
      dhcp4: true
      dhcp-identifier: mac
      critical: true
      nameservers:
         addresses: ["<LAN IP address of router>"]

Then

sudo netplan --debug generate
sudo netplan apply
sudo reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.