13

Since I bought a new laptop, during already two years, I have endless problems with WiFi on my laptop (Lenovo Y50-70) on Ubuntu (16.04, 18.04).

Firstly, it always disconnects from connections, such as eduroam or any other enterprise connections. I tried maaany things to solve it, but none of them worked:

  • Change IPv6 to Ignore/Disable
  • Installing/reinstalling wifi drivers (I have broadcom wifi card)
  • Connecting to the specific access point (iwlist scan and choosing the best connection according to the signal strength)
  • Adding b43 to blacklist
  • Disabling Secure Boot
  • Using Wicd Network Manager
  • And many many other things found in stackoverflow or elsewhere...

My WiFI card details:

08:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4352 802.11ac Wireless Network Adapter [14e4:43b1] (rev 03)
Subsystem: Lenovo BCM4352 802.11ac Wireless Network Adapter [17aa:0623]
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 17
Region 0: Memory at d1600000 (64-bit, non-prefetchable) [size=32K]
Region 2: Memory at d1400000 (64-bit, non-prefetchable) [size=2M]
Capabilities: <access denied>
Kernel driver in use: wl
Kernel modules: bcma, wl

Now, I was trying to play with drivers etc... And endup with a biger problem. Now, when I connect to the eduroam I can use it for 5-10 minutes after it disconnects and never connects back, also all wifi connections disappears. In the syslog, on disconnect I caught this error: https://pastebin.com/FxP7PmPn To connect again I need to unbind and bind again wl driver:

sudo rmmod wl

sudo modprobe wl

Maybe someone can explain why it happens to me? Is it possible to fix? I really tired of that for 2 years...

Some details:

  • Laptop: Lenovo Y50-70
  • OS: Ubuntu 18.04 LTS
  • I have dual boot with Windows 10
  • I installed wifi drivers using command:

    apt-get install bcmwl-kernel-source 
    

If you need more details - let me know.

Also this (output from command rfkill list all):

2: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
4: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
11: phy3: Wireless LAN
    Soft blocked: no
    Hard blocked: no
12: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Thank you for any kind of help.

UPDATE: I bought TP-Link (TL-WN725N) wifi usb adapter and tried to use it with eduroam networks. I can confirm that the problem is still the same - it disconnects after some time and it's very difficult to connect again. I need to restart network-manager several times or unload and load r8188eu module. Of course, there are no errors in the syslog which I posted above, but still...

17
  • You should be using the broadcom-sta-dkms driver. Uninstall all other broadcom drivers first. Report back to @heynnema
    – heynnema
    Oct 25 '18 at 18:16
  • Hello, @heynnema. Thank you for help. But I already tried to do so. I uninstalled bcmwl-kernel-source, and installed broadcom-sta-dkms drivers. I used these commands: apt-get purge bcmwl-kernel-source apt-get install broadcom-sta-dkms Although the crash is gone from syslog, but I still have the same problem and I always see this error: cfg80211_inform_bss_frame error
    – Tomas
    Oct 27 '18 at 13:08
  • Edit your question with the output of sudo debsums -s. Report back to @heynnema
    – heynnema
    Oct 28 '18 at 23:19
  • @heynnema I had the same errors, so I switched back to bcmwl-kernel-source.
    – Tomas
    Oct 29 '18 at 14:23
  • Note that the dkms driver will rebuild itself after Software Updates that update the kernel. Did you do debsums yet?
    – heynnema
    Oct 29 '18 at 14:30

10 Answers 10

14

FINALLY. I can confirm that since two years I finally fixed my wifi problem. The solution was actually super easy and near to me: I had to change REGDOMAIN in crda (I had there different country code):

  1. sudo -H gedit /etc/default/crda

  2. REGDOMAIN=<YOUR COUNTRY CODE>

  3. reboot (mandatory!!)

You can take your country code from here.

To sum up, I'm using bcmwl-kernel-source wl driver for my Broadcom BCM4352 card. (good info/tutorial about it is here). I still receive sometimes those errors and have few small timeouts for ~1 second (no disconnects!), but I think it's natural and it doesn't bother me compared to what I had before...

4
  • 2
    Glad you found a solution. Whenever you open a graphic application with sudo from the command line, you should use sudo -H or you may mess up things in your own home directory. I'll let you do the edit :-)
    – heynnema
    Oct 29 '18 at 20:33
  • Did not solve the issue for me, unfortunately.
    – Cleb
    Jul 3 '19 at 20:17
  • Thank you so much. Now my wifi actually scans for networks again!
    – hullunist
    Oct 8 '19 at 20:29
  • Worked like a charm for me! Thanks a lot! Jan 30 at 15:12
1

sudo -H gedit /etc/default/crda

REGDOMAIN=[YOUR COUNTRY CODE]

reboot (mandatory!!)

Fun fact: works the other way around too. My PC had that issue and Tomas' solution did the trick. My laptop on the other hand worked just fine but I thought might as well take precautions. Put my country code and rebooted the system. Had the exact same issue with the country code on my laptop as I had without country code on my PC. I just undid what I had changed, rebooted again, and everything went back to working normally. I don't quite understand why that happened but I wanted to share this regardless. Could help one person at least. I would have simply commented but I can't do that yet because I'm new.

0

I had this problem, my wifi connection was extremely slow while it worked on Windows. After trying several suggestions on the internet, the wifi disappeared after a time running and it only came back after restarting the laptop. The following worked like a charm for me (no problems since knocks on wood):

sudo modprobe -r rtl8723de && sleep 5 && sudo modprobe rtl8723de ant_sel=1

or if that doesn't work:

sudo modprobe -r rtl8723de && sleep 5 && sudo modprobe rtl8723de ant_sel=2

it was fixed.

2
  • Isn't it only for Realtek wifi cards? Because I'm using Broadcom. What card do you use? lspci -vvnn | grep -A 9 Network
    – Tomas
    Oct 25 '18 at 14:28
  • Might be, I have a Realtek wifi card.
    – Pepijn
    Oct 25 '18 at 15:10
0

this page may be of help to you. One thing that may help also is if it's a uefi machine you need to disable secure boot.

2
  • I just figured out, that I was running on Legacy boot mode (not UEFI) and I couldn't disabled secure boot. So, I changed boot mode to UEFI and disabled secure boot and reinstalled broadcom drivers. Currently, no errors in log and wifi works fine (but at home's wifi), I'll check later how it is going with eduroam and others enterprise wifi networks.
    – Tomas
    Oct 27 '18 at 14:16
  • I can confirm that problem still exists...
    – Tomas
    Oct 27 '18 at 18:26
0

I was running Ubuntu in Legacy boot mode and was also using an old version of BIOS. After updating the BIOS and starting Ubuntu in UEFI boot mode, my WiFi adapter works like a charm.

Laptop: Dell Inspiron 3521
Wifi Adapter: QCA9565 / AR9565 Wireless Network Adapter

0
sudo modprobe -r rtl8723de && sleep 5 && sudo modprobe rtl8723de ant_sel=1

or if that doesn't work:

sudo modprobe -r rtl8723de && sleep 5 && sudo modprobe rtl8723de ant_sel=2

it was fixed. THIS ONE WORKED FOR ME BUT ANY IDEA HOW TO MAKE IT PERMANENT ? PLEASE

0

sudo modprobe -r rtl8723de && sleep 5 && sudo modprobe rtl8723de ant_sel=2

This helped me increase the wifi signal but when I restart my computer I have to apply the command again . How to set it permanent. Please

0

This is an Old'ish thread but to make the change permanent:

echo "options rtl8723de ant_sel=X" | sudo tee /etc/modprobe.d/rtl8723de.conf

Replace X with the correct number that works for you

-1

I am not exactly a programmer. Meaning I do not write code. But I have had this wi-fi disconnect problem for over a year using Ubuntu 18.04 I tried every fix on the Internet. Nothing seemed to work for long. I was also trying to extend the timing for the sleep mode.

So I went to settings. Under POWER I set the Blank Screen to NEVER. Not knowing what I was doing, I set the Turn Off WIFI to Save Power to OFF. I also turned off the Bluetooth. Well as you guessed, I had no WIFI. SO I went back to Settings and set the Turn Off WIFI to Save Power to ON. I got no idea what that did, but the WIFI has been on for over a half hour with no disconnect.

Maybe the Bluetooth had something to do with it. Anyway, I was also tired of my phone trying to connect to the Laptop when the Laptop was shut down. And the phone taking 5 minutes to connect to my headphones. I'll give this a few days and check back later.

-1

I would like to assist you on this issue. I had this problem as well.

The problem is during installation - The installation disc lacks of some packages. Here's a link where I talked about this issue...

http://boards.4channel.org/g/thread/74620643#p74620657

DOWNLOAD THIS PACKAGE AND ITS DEPENDENCIES:

http://mirrors.kernel.org/ubuntu/pool/restricted/b/bcmwl/bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu4_amd64.deb

http://mirrors.kernel.org/ubuntu/pool/restricted/b/bcmwl/bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu4_i386.deb

NOW GO TO DRIVER MANAGER AND SELECT bcmwl-kernel-source

If isn't working, please, go and install bcmwl and its dependencies first:

http://mirrors.edge.kernel.org/ubuntu/pool/restricted/b/bcmwl/

I hope this info could help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.