0

I tried to update/upgrade my apt and I get the error from python3 depends.

When I Update/Upgrade:

praz@abuahmed:~$ APTGET
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://dl.google.com/linux/chrome/deb stable Release                                                        
Hit:3 http://ppa.launchpad.net/noobslab/apps/ubuntu bionic InRelease                                                                                 
Hit:4 https://desktop-download.mendeley.com/download/apt stable InRelease                                                                            
Hit:5 http://id.archive.ubuntu.com/ubuntu bionic InRelease                                     
Get:6 http://security.ubuntu.com/ubuntu bionic-security InRelease [83,2 kB]
Get:8 http://id.archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]         
Hit:9 http://id.archive.ubuntu.com/ubuntu bionic-proposed InRelease                              
Fetched 172 kB in 3s (52,7 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  python3-distutils python3-gdbm python3-lib2to3
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

When I Upgrade that packages:

praz@abuahmed:~$ sudo apt-get upgrade python3-distutils python3-gdbm python3-lib2to3
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python3-distutils : Depends: python3 (>= 3.6.6-1~) but 3.6.5-3ubuntu1 is to be installed
 python3-gdbm : Depends: python3 (>= 3.6.6-1~) but 3.6.5-3ubuntu1 is to be installed
 python3-lib2to3 : Depends: python3 (>= 3.6.6-1~) but 3.6.5-3ubuntu1 is to be installed
E: Broken packages

When I checked my apt policy

praz@abuahmed:~$ sudo apt-cache policy python3-distutils python3-gdbm python3-lib2to3
python3-distutils:
  Installed: 3.6.5-3
  Candidate: 3.6.7-1~18.04
  Version table:
     3.6.7-1~18.04 500
        500 http://id.archive.ubuntu.com/ubuntu bionic-proposed/main amd64 Packages
        500 http://id.archive.ubuntu.com/ubuntu bionic-proposed/main i386 Packages
 *** 3.6.5-3 500
        500 http://id.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        500 http://id.archive.ubuntu.com/ubuntu bionic/main i386 Packages
        100 /var/lib/dpkg/status
python3-gdbm:
  Installed: 3.6.5-3
  Candidate: 3.6.7-1~18.04
  Version table:
     3.6.7-1~18.04 500
        500 http://id.archive.ubuntu.com/ubuntu bionic-proposed/main amd64 Packages
 *** 3.6.5-3 500
        500 http://id.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
python3-lib2to3:
  Installed: 3.6.5-3
  Candidate: 3.6.7-1~18.04
  Version table:
     3.6.7-1~18.04 500
        500 http://id.archive.ubuntu.com/ubuntu bionic-proposed/main amd64 Packages
        500 http://id.archive.ubuntu.com/ubuntu bionic-proposed/main i386 Packages
 *** 3.6.5-3 500
        500 http://id.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        500 http://id.archive.ubuntu.com/ubuntu bionic/main i386 Packages
        100 /var/lib/dpkg/status

I tried to fix it using Synaptic using Mark All Upgrades && Edit+Fix Broken Packages && Reload that will showed a list apt upgradable on status section and tried Mark For Upgrade at every packages to need upgradable but I didn't get the option to solved that.

  • 1
    Looks like version conflicts caused by the bionic-proposed repository. Disable that repo, run a fresh apt update (because your sources changed), then try apt upgrade again. – user535733 Oct 25 '18 at 12:30
0

@user535733 is right, the three packages from python3 depends had conflicted, between:

 python3-distutils=3.6.7-1~ from bionic-proposed/main repository
 python3-gdbm=3.6.7-1~ from bionic-proposed/main repository
 python3-lib2to3=3.6.7-1~ from bionic-proposed/main repository

and

 python3-distutils=3.6.5-3~ from bionic/main repository
 python3-gdbm=3.6.5-3~ from bionic/main repository
 python3-lib2to3=3.6.5-3~ from bionic/main repository

that's fixed with disable bionic-proposed repository using add # in

#deb http://id.archive.ubuntu.com/ubuntu/ bionic-proposed universe restricted main multiverse.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.