1

I am trying to install CUnit by using following steps:

  1. Downloaded CUnit package from SourceForge.

  2. Uncompressed it using the command:

    tar xjf CUnit-2.1-3.tar.bz2
    
  3. Then went into the CUnit-2.1-3 directory.

    cd CUnit-2.1.2
    
  4. Tried running the following sequence of commands:

    mkdir -p $HOME/local  
    ./configure --prefix=$HOME/local # but this command is not working  
    

    bash is displaying the following message:

    bash: ./configure: No such file or directory
    
  • Do you execute the ./configure command from within the CUnit-2.1.2 directory? Please check. If so, is there a file called configure in the directory? Do ls to find out. – Jos Oct 25 '18 at 10:07
0

The instructions in the INSTALL file say:

cd to the directory containing the package's source code and type ./configure to configure the package for your system.

The command that you tried to run in step 3 of the question is incorrect. It should be:

cd CUnit-2.1-3  

That is the reason why ./configure --prefix=$HOME/local returned bash: ./configure: No such file or directory

  • If this were the case, then the cd would return an error. I think that's a typo in the question. – ayman Oct 30 '18 at 4:22
  • 1
    configure is already in the CUnit-2.1-3 directory so ./configure --prefix=$HOME/local should be able to find it. – karel Oct 30 '18 at 4:27
0

Actually buried in the INSTALL file it says autoconf creates the config file. In the README it's more explicit:

The usual sequence of steps should succeed in building and installing CUnit: 1. aclocal (if necessary) 2. autoconf (if necessary) 3. automake (if necessary) 4. chmod u+x configure (if necessary) 5. ./configure --prefix <Your choice of directory for installation> 6. make 7. make install

0

This answer helped: https://askubuntu.com/a/27679/940185

libtoolize --force
aclocal
autoheader
automake --force-missing --add-missing
autoconf
./configure

Also, I used wget with direct download link (then renamed file so that only stuff before ? was left).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.