0

Upgraded from 18.04 to 18.10.

The GTK theme and icons are working except the Gnome shell theme. It lists the package as installed but it doesn't show up in Gnome Tweaks.

$ apt-cache policy yaru-theme-gnome-shell
yaru-theme-gnome-shell:
  Installed: 18.10.6
  Candidate: 18.10.6
  Version table:
 *** 18.10.6 500
        500 http://us.archive.ubuntu.com/ubuntu cosmic/main amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu cosmic/main i386 Packages
        100 /var/lib/dpkg/status

enter image description here

I tried these commands but the problem persists:

sudo apt-get --reinstall install ubuntu-session
sudo apt-get --reinstall install yaru-*
  • It's the default theme. /usr/share/gnome-shell/theme/yaru/gnome-shell. css – PRATAP Oct 25 '18 at 9:22
  • That's Adwaita for me. – Ubuntuthrow Oct 25 '18 at 9:26
  • I'm saying Default isn't Yaru for me it's Adwaita. There's no gnome-shell.css in /usr/share/gnome-shell/theme/Yaru either. Edit: Sorry I'm blind it is there. – Ubuntuthrow Oct 25 '18 at 9:30
  • that theme will be shown as "Default" in Gnome Tweaks under Shell Themes tab.. – PRATAP Oct 25 '18 at 9:52
  • Another yaru puzzle here: askubuntu.com/questions/1086339/… – DK Bose Oct 25 '18 at 10:45
0

Since you upgraded from 18.04: do you have a specific session for the new theme on the login window? I installed the communitheme, and that's how that works on 18.04. You need to log in using a session using the new theme.

  • It gets installed with 18.10 and it's like a normal theme. There is no session specific to it. – Ubuntuthrow Oct 25 '18 at 17:40
0

I had the same issue

sudo apt-get --reinstall install ubuntu-session
sudo apt-get --reinstall install yaru-*

worked for me, but I had to restart to finally see Yaru listed in the tweaks tool.

Here is the reported bug to track the 'official' solution:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.