0

I am running a C++ program which wants to enforce its own scheduling policy. It keeps giving warnings that it doesn't have the rights to, and I want to give it all the rights that it wants!

I tried doing:

sudo nano /etc/security/limits.conf

and adding:

@users          -       rtprio          99
@users          -       nice            -19

Then I did: sudo usermod -aG users gsamaras, where gsamaras is me, the one and only user.

After closing the terminal, and trying again, it still gives the warnings.

I also tried using gsamaras instead of @users in limits.conf directly, but still no luck. Any ideas?

1

After changing user groups, or editing /etc/security/limits.conf, you need to logout and login again to make it work.

They are not going to be effective right away in your current session.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.