7

After upgrading to 18.10 I am experiencing very strange behaviour of gnome extensions. After my laptop goes into hibernation they all switch off and enabling them back on https://extensions.gnome.org/local/ doesn't help: nothing changes and when I refresh the page they are disabled again.

The only way to turn them back on is to reinstall them.

0
8

As per GNOME's security policy, whenever you hibernate or suspend or even lock your screen, all of your extensions get disabled automatically until you get back in, and only then the extensions get re-enabled. It seems in your case somehow the re-enabling process is not getting executed properly. This should be considered a bug, consider reporting at launchpad.net.

Also as a workaround after getting back from hibernation / suspension / lock-screen, restart GNOME shell once by pressing Alt+F2 then typing r, and finally pressing Enter, the extensions should start work again.

6
  • Thanks. Any suggestions about what to try to reinstall? – Egor Ignatenkov Oct 25 '18 at 15:22
  • @EgorIgnatenkov Bugs like this pop up every now and then, not sure what's causing the issue in your case. Consider reporting a bug against the gnome-shell package at launchpad.net. – pomsky Oct 25 '18 at 15:33
  • On my 18.10 laptop ALT+F2 r doesn't restart the extensions, I have to bring up GNOME tweaks and re-enable them from there. Didn't use to be an issue before the 18.10 upgrade (ie worked fine on 18.04). What's peculiar is that the Ubuntu dock extension does appear to re-enable itself ok – sxc731 Dec 23 '18 at 12:07
  • 2
    I am facing this issue of gnome extensions turning off after waking from sleep on Ubuntu 18.04 too (noticed since past 1-2 weeks). Alt+F2 then r solved my issue. – dmishra Jan 28 '19 at 1:42
  • 2
    Can confirm this new and very annoying behaviour on 18.04. It's even happening after locking/unlocking the screen. On 18.10 it seems to be fixed since about the same time it occured on 18.04. :| – Axel Morgner Feb 5 '19 at 7:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.