1

When trying to run a game, I got the error message

`/home/relax/.config/itch/apps/white/Whitev2/White: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory`

I googled around, and the most common solution was to install libssl1.0.0. I already had it installed, so that didn't solve the problem. I figured out that the problem might have been that libcrypto.so.1.0.0 was in /usr/lib/x86_64-linux-gnu/, rather than in /lib/x86_64-linux-gnu/, like most applications might have expected it to be. I tried creating a symlink, but that also didn't solve the problem.

  • Providing a link to the game you are trying to play could be useful.. – doug Oct 25 '18 at 0:15
  • bedstuck.itch.io/white I also experience the same error when trying to run Undertale. – Caleb Burton Oct 29 '18 at 4:56
0

White is a 32bit binary that depends on a number of i386 libs. You'll need to install all of them. Running ldd /path/to/White will show which ones are missing.

In your case you're likely only missing 1 (maybe you have wine installed which will install quite a number of i386 packages.

So run this & try again,

sudo apt install libssl1.0.0:i386

  • Oh dang, thanks! That was pretty obvious, in hindsight. – Caleb Burton Nov 15 '18 at 22:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.