1

I'm trying to make wifi work on this ThinkPad notebook, but got no success so far. Can anyone help me to fix this? Here are some informations on the system:

lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.1 LTS
Release:    18.04
Codename:   bionic

uname -r

4.15.0-36-generic

lspci -nnk | grep net -A3

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)
    Subsystem: Lenovo RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [17aa:5068]
    Kernel driver in use: r8169
    Kernel modules: r8169
05:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device [10ec:b822]

lspci -nn

00:00.0 Host bridge [0600]: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers [8086:5914] (rev 08)
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 620 [8086:5917] (rev 07)
00:08.0 System peripheral [0880]: Intel Corporation Skylake Gaussian Mixture Model [8086:1911]
00:14.0 USB controller [0c03]: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller [8086:9d2f] (rev 21)
00:14.2 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Thermal subsystem [8086:9d31] (rev 21)
00:16.0 Communication controller [0780]: Intel Corporation Sunrise Point-LP CSME HECI #1 [8086:9d3a] (rev 21)
00:17.0 SATA controller [0106]: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] [8086:9d03] (rev 21)
00:1c.0 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port [8086:9d10] (rev f1)
00:1c.4 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 [8086:9d14] (rev f1)
00:1d.0 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #9 [8086:9d18] (rev f1)
00:1d.2 PCI bridge [0604]: Intel Corporation Device [8086:9d1a] (rev f1)
00:1d.3 PCI bridge [0604]: Intel Corporation Device [8086:9d1b] (rev f1)
00:1f.0 ISA bridge [0601]: Intel Corporation Device [8086:9d4e] (rev 21)
00:1f.2 Memory controller [0580]: Intel Corporation Sunrise Point-LP PMC [8086:9d21] (rev 21)
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d71] (rev 21)
00:1f.4 SMBus [0c05]: Intel Corporation Sunrise Point-LP SMBus [8086:9d23] (rev 21)
02:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Polaris12 [1002:699f] (rev c0)
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)
05:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device [10ec:b822]
06:00.0 SD Host controller [0805]: O2 Micro, Inc. SD/MMC Card Reader Controller [1217:8621] (rev 01)

sudo lshw -C network

  *-network                 
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: enp3s0
       version: 10
       serial: 64:1c:67:9a:fb:e4
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168g-3_0.0.1 04/23/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:16 ioport:c000(size=256) memory:f1204000-f1204fff memory:f1200000-f1203fff
  *-network
       description: Ethernet interface
       physical id: 2
       logical name: docker0
       serial: 02:42:5b:4d:e7:68
       capabilities: ethernet physical
       configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A ip=172.17.0.1 link=no multicast=yes

Tried this answer, got this error in the last step:

modprobe: ERROR: could not insert '8821ce': Required key not available

Tried this answer, got this error in the last step:

modprobe: ERROR: could not insert 'rtl8723de': Required key not available

Tried this answer (/a/998182/885763), got this error right in sudo make install:

make -C /lib/modules/4.15.0-36-generic/build M=/home/lucas/Documents/driver/rtlwifi-next modules
make[1]: Entering directory '/usr/src/linux-headers-4.15.0-36-generic'
  CC [M]  /home/lucas/Documents/driver/rtlwifi-next/base.o
/home/lucas/Documents/driver/rtlwifi-next/base.c: In function ‘_rtl_init_deferred_work’:
/home/lucas/Documents/driver/rtlwifi-next/base.c:460:2: error: implicit declaration of function ‘setup_timer’; did you mean ‘sk_stop_timer’? [-Werror=implicit-function-declaration]
  setup_timer(&rtlpriv->works.watchdog_timer,
  ^~~~~~~~~~~
  sk_stop_timer
cc1: some warnings being treated as errors
scripts/Makefile.build:332: recipe for target '/home/lucas/Documents/driver/rtlwifi-next/base.o' failed
make[2]: *** [/home/lucas/Documents/driver/rtlwifi-next/base.o] Error 1
Makefile:1551: recipe for target '_module_/home/lucas/Documents/driver/rtlwifi-next' failed
make[1]: *** [_module_/home/lucas/Documents/driver/rtlwifi-next] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.15.0-36-generic'
Makefile:100: recipe for target 'all' failed
make: *** [all] Error 2

Thanks for the attention!

1

What worked for me was disabling Secure Boot, following more or less the instructions given in this answer and this post. From the latter I'll be copying most of the steps (Method 2), just to keep this whole question complete by itself.

1) Run sudo mokutil --disable-validation and choose an easy password (like 12345678).

2) Reboot the system and press any key when you see the blue screen (MOK management).

3) Select Change Secure Boot state.

4) Enter the password you had selected in Step 1 and press Enter, paying attention to the description.

5) Select Yes to disable Secure Boot in shim-signed.

6) Press Enter key to finish the whole procedure.

7) After this you should be able to reboot and connect to your Wifi normally.

To re-enable Secure Boot validation in shim, simply run sudo mokutil --enable-validation.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.