10

Ubuntu 18.04LTS, I run the updates, restarted the computer and there is no sound/audio in the Chrome. Sound works in other applciations, system sounds works, in the Settings I can see Chrome as a application - sound is ON and it should work, but it doesn't.

Any ideas? It happend just after system update.

1
  • I have the same problem. However for me Chromium is not even registering with the pulse daemon. I remember a while back that I modified some pulse settings to prevent the "chrome sends audio to something without speakers" problem. But now I'm not seeing the input side from chromium, so it's not going to the wrong sink. – rew Jan 18 '19 at 16:50
16

I downloaded PAVUCONTROL, checked settings, chrome was sending audio to HDMI port, changed it, works well now.

0
6

Do like in this AskUbuntu question:

Update:
The following seems to prevent the problem from reappearing in the future:

Edit /etc/pulse/default.pa, find the line that starts with load-module module-stream-restore and add restore_device=false at the end, so that the line looks like this:

load-module module-stream-restore restore_device=false

Then do a

killall pulseaudio

and restart chrome... and all is fine.
No other plugins to install or change.

1
  • Perfect. Worked for me on OpenSuse 42.3 with Chrome 77 unstable. – Tom Russell Jun 17 '19 at 20:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.