7

I am Ubuntu 18.04 lts Budgie, and somehow whenever I am not moving my mouse, either on fullscreen or not, the video freezes, until I move my mouse again. It happens all the time, on Chrome and Chromium.

I do have Nvidia proprietary driver installed.

Someone asked something similar but for Ubuntu 11, and It's a bit outdated.

Edit: it doesn't happen on Firefox from what I have seen so far.

Thanks in advance :)

  • it freezes immediately when you stop moving the mouse or after some time? – pLumo Oct 24 '18 at 7:36
  • @RoVo Immediately. maybe a second or two but it's almost instantly – Argaman Oct 24 '18 at 7:45
  • It happens for me on Ubuntu Budgie 18.04 and evergreen Firefox Developer Edition... – Marecky Feb 17 '19 at 17:48
  • @Argaman II think they solved the issue in a recent update. – Santropedro Apr 8 '19 at 3:20
8

It is happening to me either in Ubuntu Budgie 18.04.

How to fix: Disable the hardware acceleration in your browser:

  • Chromium/Chrome.
  • Search 'hardware'.
  • Uncheck Use hardware acceleration when available.
  • Restart browser.

Best regards.

| improve this answer | |
  • However be aware that this will cause a much higher CPU usage especially when watching videos in high qualities – Pieter De Clercq Feb 2 '19 at 8:54
  • @PieterDeClercq I care about freeze videos, not higher CPU ;) – Costales Feb 2 '19 at 13:56
3

I found a fix without any throwbacks!

It's sufficient to start chromium with the flag --disable-gpu-vsync and the problem completely goes away.

It's possible to make chromium start with this flag by default, just execute this command in the terminal, restart chrome and the issue will be gone forever:

sudo sh -c 'echo "CHROMIUM_FLAGS=--disable-gpu-vsync" > /etc/chromium-browser/customizations/10-gpufix'
| improve this answer | |
  • 1
    Thank you for trying to help after so long :) I will indeed try your solution, but does it work for chrome as well? Because this is my main browser, I tested the issue on Chromium just because I was curious, but thank you nonetheless :) – Argaman Dec 21 '18 at 5:23
  • 1
    @Argaman the flag works with chrome too, i just don't know how to set it by default at the moment (you'll have to start it from terminal every time). Just switch to chromium as your main browser: it's identical to chrome and it's even completely open source. – rikial Dec 21 '18 at 18:32
  • Hi @rikial the command above writes a file into the default config directory for chrome / chromium. It seems that Chrome uses the same too. It will work withut the shell. – runlevel0 Jan 5 '19 at 23:23
0

It's probably a bug on Chrome or your Adblocker. Disable all addons and try it again. I had the same problem only with Chrome and when they updated Chrome it was solved. I installed all the newest drivers, checked RAM for errors and checked the BIOS version. But it was a bug from Google Chrome... :P You can also try to uninstall and install Chrome again. Some people helped this.

| improve this answer | |
  • I disabled all addons and I tried to reinstall Chrome, but unfortunately it did not help :( Thanks for trying to help though :) – Argaman Oct 24 '18 at 9:22
0

I found an alternative solution to disable vsync for Intel cards too:

I found it in the ArchWiki and it's pretty simple and does not require root access:

Simple create a file in your $HOME called .drirc and add the following:

 <device screen="0" driver="dri2">
    <application name="Default">
        <option name="vblank_mode" value="0"/>
    </application>
</device>

Source: Archwiki: Disable VSYNC Intel Graphic Cards

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.