0

I have my Sennheiser GSX 1000 External DAC/AMP setup through editing the pulseaudio config. I can run the command "aplay -1" and I can see my GSX on devices 1,0 and 1,1 but when I reboot the system and run the command again the devices move to 3,0 and 3,1 causing pulseaudio to break. I can run "alsa force-reload" and my GSX is back to devices 1,0 and 1,1 so I have sound again. Can anyone tell me why my GSX is changing device card id when rebooting and what to do to stop it?

  • Other sound devices got that number first. What other devices do you have? – CL. Oct 24 '18 at 6:09
  • The two front and back audio jacks on my PC, the audio jack that's integrated into a usb 3.0 hub I have plugged in and the HDMI audio devices for both my 760 and R9 390. – ChucMCCluck Oct 24 '18 at 6:21
0

When the system is booted, the first sound card number is assigned to the first driver that happens to report that a device has been found.

To prevent other drivers from getting the first two numbers, add the following to some .conf file in /etc/modprobe.d/:

options snd slots=snd-usb-audio,snd-usb-audio

To fix the order of the two USB audio devices, add the following line:

options snd-usb-audio index=0,1 vid=0xAAAA,0xCCCC pid=0xBBBB,0xDDDD

where AAAADDDD can be found in the output of lsusb:

$ lsusb
Bus *** Device ***: ID ****:**** Linux Foundation 2.0 root hub
Bus *** Device ***: ID AAAA:BBBB The Hub Audio Thingy
Bus *** Device ***: ID CCCC:DDDD Sennheiser GSX 1000
Bus *** Device ***: ID ****:**** USB Toaster
...

See https://alsa.opensrc.org/MultipleUSBAudioDevices for a longer explanation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.