0

I was using gdm3 in Ubuntu 18.04, after upgrading it stopped working (Similar screenshot in gdm3 does not start in ubuntu 18.04) I had no login screen.

Using tty I tried (from: Can't start ubuntu-desktop after upgrade to 18.04):

sudo systemctl start graphical.target

This worked for a while, the graphical interface was started, so for testing purpose, I closed my session and I was able to enter again, but after a reboot the problem was back again, so from tty I had to change gdm to lightdm. Is it worth trying to get gdm working again?

1

You may have a problem with an older computer, with an older GPU. Try this...

  • boot to recovery mode
  • choose root access

type:

sudo mount -o remount,rw /      # to remount the disk r/w

sudo pico /etc/gdm3/custom.conf # edit this file

change:

#WaylandEnable=false

to:

WaylandEnable=false

Then reboot.

1
  • @Madbyte glad that worked for you! – heynnema Oct 25 '18 at 2:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.