I installed Elisa music player from Flathub, but it refuses to see my Music partition, so I can't add any music to it's library unless I copy it to /home/my_user/.

Is there a way to give a Flatpak application permission to access non canonical addresses?

Aside from specifying it when compiling it...


You can do this via the command line. The specific command you need is (it may need to be run as sudo):

flatpak override <package_name_here> --filesystem=<path_here>

If you have an odd path & it complains about an "unexpected filesystem suffix", just put the path part in quotes.

A more complete list of permissions commands is found here - http://docs.flatpak.org/en/latest/sandbox-permissions.html

  • Thanks, I can add Dropbox folder to the WPS Office path – Indacochea Wachín Apr 19 '19 at 14:35

To add to the other answer, another solution that worked for me was installing Flatseal. It makes setting permissions super easy and also has the added benefit of making the existing permissions really clear. Here's what adding a directory to steam looks like in Flatseal:

Adding extra directory to steam in Flatseal

I added the directory "MediaSSD" there, everything else is default.

  • Changing permissions might also reset all the preferences, at least this is what happened with Thunderbird. All the account settings were done, but, at least, now I can drag/drop files to attach them to messages! – Cosmin Saveanu Nov 13 '20 at 11:09
  • Thank you! This is golden :) – yanike Mar 26 at 10:37
  • This app is awesome. Wish I would have known about it sooner. – Buttink Jun 15 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.