23

I just installed Ubuntu 18 on my desktop PC alongside Windows 10 and have been using Ubuntu without any problems for a couple of days. Today, when I booted up my computer, I am no longer able to open the terminal at all. I've tried restarting it multiple times, but it still won't work. If I click the terminal icon on my task bar, nothing happens. If I try opening the terminal with CTRL+ALT+t, it still doesn't work.

How can I resolve this?

13
  • 2
    No, the terminal doesn't show when I Alt+Tab – John Seed Oct 23 '18 at 19:42
  • 2
    When I run gnome-terminal from xterm, nothing happens.. – John Seed Oct 23 '18 at 23:30
  • 2
    After doing a fresh install of Ubuntu, once again the terminal is not showing when I open it. When I look in the System Monitor is shows that gnome-terminal is running, but there is no terminal visible whatsoever... – John Seed Oct 24 '18 at 23:37
  • 3
    Same here. And that's crazy. One of the most important features of linux - running a console window - is broken. In a LTS release! (We're not talking about a dev version here!) – Regis May Mar 22 '19 at 14:48
  • 1
    @FaustoR. I just created an answer to a similar question with a solution for this issue: askubuntu.com/a/1143596/167115 – mchid May 15 '19 at 23:52
34

I had the same problem. After updating python to version 3.7 some applications like jupyter notebook, meld and the terminal did not launch.

The solution: Symbolic link to python3.4" was lost:

sudo apt-get --reinstall install python3-minimal
3
  • 4
    You can download Visual Studio Code and use it's built-in terminal - I had this same problem and I fixed it using the Visual Studio Code terminal via running the various commands through that terminal to fix the Python stuff code.visualstudio.com/#alt-downloads – Kyle Bridenstine Mar 25 '20 at 19:21
  • JetBrain products also have terminals and works too. – Ulrik McArdle Apr 10 '20 at 0:30
  • i tried all other solutions in stack overflow, but only this worked. Thanks a lot – aahnik Oct 2 '20 at 16:26
9

The same problem happened with me. The reason is that the python version is 3.7. You can download and say any terminal for solution. I used the terminal of visual code.

The code you need to enter is:

sudo update-alternatives --config python3

Then you should choose a version lower than python 3.7. I choose python3.6. So I write 1 and confirm.

If the problem persists, you can rewrite it.

Example:

visual code terminal with commands

4

Did you update your python3?
If yes, then this will be the solution:

  1. Ctrl+Alt+F1 to open xterm.
  2. Enter your username.
  3. Enter your password.
  4. Type this command:

    sudo update-alternatives --config python3
    
  5. Select option 1.
  6. Ctrl+Alt+F7 to return to GUI
2
  • 1
    This is not helpful since option 1 may be any Python version (incl. 3.7 which seems to cause the issues). – Julian L. Mar 5 '20 at 7:53
  • 1
    You can download Visual Studio Code and use it's built-in terminal - I had this same problem and I fixed it using the Visual Studio Code terminal via running the various commands through that terminal to fix the Python stuff code.visualstudio.com/#alt-downloads – Kyle Bridenstine Mar 25 '20 at 19:21
2

I also second Allen's answer but you don't really need xterm. Just right-click on a point in desktop and choose "open terminal". It works that way. Then type

sudo update-alternatives --config python3

and choose a lower Python version as mentioned before.

0

If you want to update python then , first install tilix because terminal will not work after updating python but tilix will work.You can perform any task in tilix like terminal.

-1

You can use ctrl+alt+F1 up to F6 to open multiple terminals in text mode. If you want to return to GUI press ctrl+alt+F7.

Not the answer you're looking for? Browse other questions tagged or ask your own question.