0

I don't understand the bad usage that is happening here. I am trying to mount a samba share (NAS) and I get mount: bad usage. I was under the impression mount is used:

mount <options> <localtion to mount> <local place its mounted>

So I attempted to create that with this:

sudo mount -t cifs -o username=USER, password=PASSWORD //IPADRRESS:/homes /media/backups/

I got this from the man pages and the following references (I realize some are referencing NFS when I have stated I am using samba):

[1] https://wiki.qnap.com/wiki/Talk:Mounting_an_NFS_share_on_Ubuntu

[2] https://www.digitalocean.com/community/tutorials/how-to-set-up-an-nfs-mount-on-ubuntu-16-04

[3] https://linux.die.net/man/8/mount

1
  • Don't put blanks after commas. -o username=USER,password=PASSWORD – waltinator Oct 23 '18 at 17:27
2

Several things I see:

  1. You give link to a tutorial on nfs (Network File System) and not CIFS (Common Internet File System).
  2. The format for cifs is:

    mount -t cifs //server-name/share-name /mnt/cifs -o username=USER,password=PASSWORD
    
    • No space as pointed out from previous answer, and
    • No : between IP address and share folder

So your mount command should be:

 sudo mount -t cifs -o username=USER,password=PASSWORD //IPADRRESS/homes /media/backups/
2

You have a space in your options. All of the -o options should not have any spaces between them.

Hope this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.