10

After upgrade to 18.10 Gimp 2.10 will not start. I reinstalled it but no luck.

Found this error in logs:

gimp-2.10: symbol lookup error: gimp-2.10: undefined symbol: gegl_operation_get_source_space

What could be wrong

4
  • Is that the Gimp from the Ubuntu repos or the Gimp from the PPA?
    – xenoid
    Commented Oct 23, 2018 at 17:25
  • From the Software Center so I guess Ubuntu repos, right? Used PPA before in 18.04 for previous version of Gimp Commented Oct 23, 2018 at 19:14
  • I don't think I have gegl installed. How do I check that and install it on Ubuntu 18.10? Commented Oct 24, 2018 at 20:22
  • Update: I have libgegl-0.4-0 Commented Oct 24, 2018 at 20:28

2 Answers 2

16

It was a problem with a local version of libgegl. Uninstalled Gimp and removed libgegl by 'sudo apt-get remove libgegl-0.4-0:amd64'. Reinstalled Gimp via Software Center, got a new libgegl from that and now it's working.

2
  • 3
    worked for me too, thanks. Others may find, as I did, that removing gimp (sudo apt remove gimp) then prompts an autoremove (sudo apt autoremove) which includes libgegl and others.
    – dez93_2000
    Commented Nov 27, 2018 at 8:11
  • Also you need to remove libgegl-common if it's installed on your system. You can find all the gegl packages here: apt search gegl
    – JavaRunner
    Commented Sep 12, 2020 at 0:40
0

For me, I had to remove Gimp, remove gegl libraries and re-install Gimp. I did:

sudo apt remove gimp
sudo apt remove *gegl* # to remove all gegl libraries. Then,
sudo apt install gimp # to reinstall Gimp. The gegl libraries are reinstalled here too.

Then it worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .