3

Is there any reason the login window would stop working and start looping? I'm running 18.04. I normally RDP into the ubuntu box, but that isn't working now. Using a keyboard and mouse, I see my username on the monitor. I type in my password. Then the screen goes blank for a few seconds... and I'm back to the login screen where my username is. I'm not getting through to my desktop!

I haven't messed with the machine except for the following, but, I'm not sure why any of these would impact the loginscreen.

But none of these messed with the login manager. Does anyone have any idea what could be up? Interestingly, nearly all of my docker containers (portainer, heimdall, tatulli, sonarr, radarr, pihole) work, with the exception of anything using ssl (plex and cockpit). I'm guessing somehow the firewall blocked port 443, but I'm not sure why that would stop me from logging into the box using a keyboard and mouse...

Any help/insight is greatly appreciated!

EDIT1: I tried creating another user via

sudo useradd -d /home/testuser testuser  
sudo passwd testuser

but the login manager still throws me for a loop

EDIT2: I've disabled the firewall via

sudo ufw disable

and I reversed the system-resolved.service work, but still no luck :(

10

I've almost done all suggestions here, but none of them didn't work. Also gd3 reconfigure has no effect. But I had suspected to my last gnome extensions.

The system-monitor@paradoxxx.zero.gmail.com was the problem. So I disabled all gnome extensions to solve login loop as following steps:

  1. Press Ctrl+Alt+F2 or Ctrl+Alt+F3 or ...
  2. Enter your username and password
  3. cd ~/.local/share/gnome-shell/
  4. mv extensions extensions.bak
  5. mkdir extensions
  6. Press Ctrl+Alt+F1
  7. Login and Thanks God

Hope help somebody else. I almost worked full day to find this solution.

PS: I've installed my favorite extentions again and I have to tell you Login Loop disaster in ubuntu has wide variety causes. So try to find your special cause and solve it.

  • This worked for me. I had an out-of-date extension (workspace-grid@mathematical.coffee.gmail.com). Copying all extensions, then adding them back one-by-one (I only had two, so it was easy) allowed me to identify this as the culprit. Thank you! – Kryten Jan 22 at 23:12
  • After two days of frantic googling re "18.04 login loop after software update" and trying all standard recipes to no avail I found your above extensions suggestion. Saved me! For me also the workspace grid. Thank YOU! – Rob Rutten Feb 1 at 16:04
  • @RobRutten , @ Kryten Happy it helped you. Thanks God :)) – Khalil Laleh Feb 2 at 8:40
  • I had to reinstall my GPU drivers and waist hours just to come across with the post. - I love you – DsCpp Apr 10 at 15:21
4

Looks like it may have been related to "upgrading" from 18.04 to 18.04.01: No login screen after ubuntu 18.04.1 update

In any case, doing the following fixed it for me:

systemctl stop gdm.service  
systemctl restart gdm.service  
sudo dpkg-reconfigure gdm3  
reboot
1

I also had tried a lot of solution but none of that work for me, but this did.

  1. Press Ctrl+Alt+F2
  2. Login with your username and password
  3. Enter ls -ld ~/ after you will see something like this drwxr-xr-x 30 root root 4096 Jul 6 20:26 /home/{yourcutename}/
  4. Now Enter sudo chown username:username /home/{yourcutename}/

This worked for me :-)

  • You'll go to heaven for this. Before almost deciding to reinstall Ubuntu I tried this and it worked. Thanks mate. – Amit Yadav Aug 25 at 11:17
1

My ubuntu loop login problem started after switching from java11 openjdk to java8 openjdk. I had logged in via CTRL+ALT+F3 to terminal and switched back to java 11 via sudo update-alternatives --config java and login loop stopped.

0

i have that same problem on Ubuntu 19.04. What i did was reinstall gnome and works fines.

sudo apt-get install gnome-session gnome

Then on the log in screen i change to gnome

0

My issue started after I messed with the /etc/environment file by adding the following to my path variable:

PATH=$JAVA_HOME:$PATH

I fixed the issue by going into one of the strips down mode in grep, launching a command prompt, launching VI and removing the above.

I believe what happens, is by messing with the path variable, Ubuntu couldn't find some things.

I initially did this because I installed java manually.

  • ** by strip down mode, I mean recovery mode – AndreGraveler Jun 13 at 0:45
  • It seems if you change the path variable manually it throws off things. Its best to do auto install. – AndreGraveler Jun 13 at 0:48
0

I faced the same problem with my Ubuntu 18.04 a couple of days ago. I tried all the mentioned solutions on the web. But I think, in the end, the problem with mine was some wonky graphics drivers. All I did was log in on my system on Ubuntu Wayland (by clicking that gear button at the time of login) opened the Terminal Window and upgraded. The commands were:

    sudo apt update
    sudo apt upgrade

And then rebooted my system. Ready as new!!! If you want you can stay and use it on Wayland, but some applications do not work properly on Wayland (like VLC).

Well, the other solutions on the web did not work for me. So, all the others and even if this solution does not work then I think only one option is left: Reinstall

0

The cause for me was that I was playing around with the DISPLAY variable and had set export DISPLAY=:1.0 in my .profile

when I commented out that line, I could log in again ie. no more looping.

0

This issue seems to have a different solution for everyone. I tried many different solutions that I found throughout forums and nothing worked for me. After looking around I found the issue was that somehow my user had lost write permissions in my own $HOME folder.... Solution for me was:

  1. Load command line (ALT+CTRL+F2 or ALT+CTRL+F3)
  2. chmod 755 $HOME
  3. restart the Desktop Environment.

Hope this can help someone else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.