2

Ubuntu 18.04 Full Disk Encryption now works on Full install flash drives.

The ability to separately encrypt home directory / home partition has been eliminated.

How to make an Encrypted BIOS/UEFI Flash Drive with different passwords for home and system using a script?

5

BIOS/UEFI Flash Drive with Full Disk Encryption

I have been playing with Paddy Landau's Manual Full System Encryption: https://ubuntuforums.org/showthread.php?t=2399092

Out of the box the script works UEFI only.

With a mkusb base, almost anything BIOS/UEFI is possible.

At this point the flash drive will be UEFI only.

enter image description here

  • Now mount the ESP boot partition and copy ESP/EFI/ubuntu/grub.cfg and overwrite ESP/boot/grub/grub.cfg.

Your Bootable flash drive will now have encrypted system, home and swap files and will boot either BIOS or UEFI.

Notes:

  • *Separate home, swap and NTFS partitions are optional.
  • Many people recommend against using swap with a bootable USB or SSD for fear of wear.
  • The swap partition, if used, can be encrypted using ecryptfs-utils.
  • The NTFS partition, if used, can be encrypted using VeraCrypt so that it can be used in both Linux and Windows.
  • If there are problems reusing the installer drive on a second encrypted install, confirm /mnt/root/ has been deleted and that the correct UUID for sdx3 has been used in fstab.
  • GParted on the encrypted drive may not work.
  • 1
    It would be a good idea to test how well this works after an update to the kernel. Please test this before placing any important data on the drives. (You should be making frequent backups anyway.) – Paddy Landau Oct 23 '18 at 11:11
  • @Paddy Landau: Thanks Paddy, will give it a try in the morning and report back. Regards – C.S.Cameron Oct 23 '18 at 15:00
  • +1: @ C.S.Cameron & @PaddyLandau, Very interesting :-) The text near the end is not quite clear - does this system boot also in BIOS mode? – sudodus Oct 23 '18 at 18:32
  • @sudodus: Yes, so far it is working BIOS and UEFI, (brilliant guy that mkusb inventor), Power here has been out a while, now trying a kernel upgrade, (which I have never tried before and will likely mess up a few times). Regards – C.S.Cameron Oct 24 '18 at 4:38
  • 1
    @Paddy Landau : Already had latest kernel update from Updates. Tried UKuu and updated from 4.15.0.38 to 4.17.19. All is well. – C.S.Cameron Oct 25 '18 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.