12

On Ubuntu 18.04 I ran sudo apt-get install tightvncserver. I then run vncserver which gives

New 'X' desktop is user:1

Starting applications specified in /etc/X11/Xvnc-session
Log file is /home/user/.vnc/user:1.log

as output. When I run more /home/user/.vnc/user:1.log I get

23/10/18 00:27:27 Xvnc version TightVNC-1.3.10
23/10/18 00:27:27 Copyright (C) 2000-2009 TightVNC Group
23/10/18 00:27:27 Copyright (C) 1999 AT&T Laboratories Cambridge
23/10/18 00:27:27 All Rights Reserved.
23/10/18 00:27:27 See http://www.tightvnc.com/ for information on TightVNC
23/10/18 00:27:27 Desktop name 'X' (user:1)
23/10/18 00:27:27 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
23/10/18 00:27:27 Listening for VNC connections on TCP port 5901
Font directory '/usr/share/fonts/X11/75dpi/' not found - ignoring
Font directory '/usr/share/fonts/X11/100dpi/' not found - ignoring
No VNC extension on display :1
Killing Xtightvnc process ID 5196

I have no idea on how to resolve this issue and cannot find anything on No VNC extension on display :1.

4
  • Did you ever find answer to this?
    – costa
    Jun 1, 2020 at 2:57
  • @costa No, unfortunately not. And as you can see, nobody answered this question up until now (2020-06-03, 14:49).
    – Adriaan
    Jun 3, 2020 at 12:49
  • I ended up using tigervncserver.
    – costa
    Jun 3, 2020 at 16:32
  • @costa Yeah I also heard of it. Hope it solves your problem. Good that you suggest it here for other people reading this post.
    – Adriaan
    Jun 3, 2020 at 18:24

2 Answers 2

2

If you have installed tigervnc before tightvnc, it has replaced some files inside /etc/X11/. /etc/X11/Xvnc-session in particular, which will now call vncconfig, that in turn writes this message. vncconfig is not part of tightvnc, so it will silently die.

To fix this you will have to replace the contents of /etc/X11/Xvnc-session with the contents of ~/.vnc/xstartup or with a call to ~/.vnc/xstartup.

-1

This cures the font problem but there is still the problem of display :1 not being recognised

apt-get install xfonts-75dpi apt-get install xfonts-100dpi

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.