2

Ubuntu 18.04 TLS has moved to CUDA 9.1 now, which deprecates the Nvidia Fermi Architecture.

I have tried installing the cuda 8 toolkit from nvidia with an --override option (to discard compiler verification) butthe installation failed as follows:

Command: sudo ./cuda_8.0.61_375.26_linux.run --override --toolkitpath /usr/local/cuda-8.0/

Output:

You are attempting to install on an unsupported configuration. Do you wish to continue?
(y)es/(n)o [ default is no ]: y

Install NVIDIA Accelerated Graphics Driver for Linux-x86_64 375.26?
(y)es/(n)o/(q)uit: n

Install the CUDA 8.0 Toolkit?
(y)es/(n)o/(q)uit: y

Enter Toolkit Location
 [ default is /usr/local/cuda-8.0 ]: /usr/local/cuda-8.0

Do you want to install a symbolic link at /usr/local/cuda?
(y)es/(n)o/(q)uit: y

Install the CUDA 8.0 Samples?
(y)es/(n)o/(q)uit: y

Enter CUDA Samples Location
 [ default is /home/user ]: 

Installing the CUDA Toolkit in /usr/local/cuda-8.0 ...
Warning: cannot find Toolkit in /usr/local/cuda-8.0. Use --toolkitpath to specify the toolkit location.
Installing the CUDA Samples in /home/user ...
sh: 1: /usr/local/cuda-8.0/bin/cuda-install-samples-8.0.sh: not found
chown: cannot access '/home/user/NVIDIA_CUDA-8.0_Samples': No such file or directory

===========
= Summary =
===========

Driver:   Not Selected
Toolkit:  Installation Failed
Samples:  Installation Failed
  • 1
    Apparently, you need to specify the toolkit location using option --toolkitpath. – francescop21 Oct 22 '18 at 16:25
  • I have already tried. Added my command in the post. – Blue Squirrel Oct 22 '18 at 16:34
  • Actually, you don't need that option, since you're installing in the default directory. Have you uninstalled any previous version of Cuda Toolkit? – francescop21 Oct 22 '18 at 17:16
  • I have tried without the option --toolkitpath, and I was getting the same error. Indeed, I have installed the default nvidia-cuda-toolkit 9.1 from the ubuntu 18.04 repos. But I removed it after realizing my architecture was deprecated. – Blue Squirrel Oct 22 '18 at 18:17
  • Make sure that there are no files remaining from the cuda 9.1 installation. – francescop21 Oct 23 '18 at 8:39
3

I have solved the issue using the following procedure:

  1. unpack .run file using the command: ./cuda*.run --tar mxvf (or sh ./cuda*.run --tar mxvf)
  2. copy unpacked file InstallUtils.pm to /usr/lib/x86_64-linux-gnu/perl-base
  3. enter command in terminal: export $PERL5LIB
1

There are two cleaner ways to solve this issue:

  1. Set current directory as perl library search path by: PERL5LIB=. sh cuda_8.0.61_375.26_linux.run your-other-options. Related link.
  2. Install the missing perl module by: sudo apt install module-install-perl. Related link

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.