Is there any tweaking involved in Ubuntu 10.10 to make the Wacom Bamboo Pen & Touch work? And is this hardware getting some love from the new multitouch framework?

If there's no multitouch support for it, then I'd fall back on the simpler (and cheaper) Wacom Bamboo Pen (to draw, no multitouch)...

ENAC's general list of Linux multitouch devices states the following regarding Wacom: "The 'wacom' kernel driver handles these, and is undergoing work to make it compliant with the kernel multitouch protocol." But is this also compatible with Ubuntu's multitouch protocol (which I understand is a different effort than the kernel's)


I'm following this thread on Ubuntu Forum about Wacom Bamboo Pen and Touch Series Development.

I think that sometimes wacom bamboo pen and touch work out of the box on Ubuntu, but many times they don't.

So for now you have to manually download latest driver from Linux Wacom Project http://linuxwacom.sourceforge.net/ and compile it yourself.

Here http://ubuntuforums.org/showpost.php?p=9805935&postcount=1124 jcannonsr say that there is also a ppa with dkms module but I haven't tried if it works.

You can find other useful information on these bug reports:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/568064 Lucid 10.04 https://bugs.launchpad.net/ubuntu/+source/linux/+bug/477105 Karmic 9.10

| improve this answer | |
sudo add-apt-repository ppa:doctormo/wacom-plus
sudo apt-get update
sudo apt-get install wacom-dkms

Thanks to Martin Owens -doctormo-

| improve this answer | |

I use the dkms module and it works in Lucid and Maverick.

The alternative is to compile the wacom module each time you have a kernel update. I did that for a while but the dkms module replaces it successfully.

| improve this answer | |

It worked out of the box in 11.04 here, but touch is quite crazy. I did try to install some driver updates and such, but it is still not solved, I will look into it soon enough and see what has gone wrong, but the pen worked perfectly OOTB.

PS... as far as I know, pen tilt is not supported, everything else works fine (pressure does of course)

| improve this answer | |

I've managed to get it to work on 10.10, too! Simply followed these instructions. Then, I created a script with some xsetwacom settings to adjust some parameters and placed it on Startup Applications.

| improve this answer | |

The Wacom Bamboo Pen currently (in 10.10) doesn't work out of the box either. I saw reports that it works with the latest upstream release of the wacom drivers though, so it might work OOTB on Ubuntu 11.04.

| improve this answer | |
  • OK, I would be fine if it's supported OOTB in 11.04 too. – Emilien Nov 2 '10 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.