2

I have a problem with the new version of Ubuntu. I used to have Ubuntu 18.04 LTS version, but I decided to change to the normal version and update it to Ubuntu 18.10. Since then I can't turn the keyboard backlight on.

I have already tried to open a terminal and type: xset led 1 ... xset led 32, but it doesn't work. I have also tried to turn it on by pressing Fn+F4 and that shows the picture of the keyboard backlight but without the blue progressbar.

Fn+F4

Does somebody know how I could fix it or what the problem is?

  • 've got the same issue on my Asus Zenbook UX410UA. Both Fn+F3 and Fn+F4 toggle shows the on-screen icon as if I'm adjusting the brightness but the actual keyboard backlight stays off. I can set the keyboard light on/off and adjusts the brightness via terminal using the following command, where 0 = off and 1, 2, and 3 are the brightness levels. But would really like to be able to use the Fn+F3 and Fn+F4 as intended. echo 3 | sudo tee /sys/class/leds/asus::kbd_backlight/brightness – Kyriakos Loizou Oct 23 '18 at 7:57
3

I was having the same issue on my UX430, to fix it just update your kernel to 4.19. You don't get the on screen display but it does now at least work

  • Worked for me too! I've reverted back to the 4.18.0-10 and I'll wait for the kernel update via Ubuntu as manually install kernels seems to require disabling secure boot in order to avoid invalid signature error and I don't wish to do that. – Kyriakos Loizou Oct 28 '18 at 18:35
  • You can easily update kernel using "Ukku Kernel Update Utility" github.com/teejee2008/ukuu Update to 5.x kernel solve all my problem on Asus UX433F (backlight, sound). – dmgl May 1 at 20:46
0

Same issue here on a MacBook Air. I can control the keyboard backlight by echoing a value into

/sys/class/leds/smc::kbd_backlight/brightness

Therefore, I thought it was not a kernel bug... and 4.19 does not solve the problem for me.

  • 4.19 does not solve the problem. – user192692 Nov 2 '18 at 18:38
  • Please edit your answer to add information and updates, do not post them in comments. I’ve done it this time for you. – Melebius Nov 7 '18 at 9:31
0

I was able to solve this.

Try browsing the /sys/class/leds/ directory. In my case I found 2 files that pertains to keyboard:

asus::kbd_backlight
asus::kbd_backlight_1

First file has 3 in it but the second has 0, so I set it to 3 as well and viola, it worked.

Now I wonder why did I had 2 files that pertains to keyboard brightness? can somebody point me to the config that reads out the files above so that I can correct which file to point it? TIA.

Note: I'm running 4.18


0

In my ZenBook pro UX580 the settings could be found in:

/sys/class/leds/asus::kbd_backlight

The file holds single value - 0. Replace it with grater number and you will have keyboard backlight on.

0

open terminal and type, hit enter

sudo /etc/acpi/asus-keyboard-backlight.sh

It will turn on your asus laptop backlight.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.