0

Trying to install Ubuntu on this PC:

ASUS Z77 Sabertooth
Intel Core i7-3770
32GB RAM

Image: ubuntu-18.10-desktop-amd64

Created boot USB on Windows using Rufus 3.3.1400.Tried [GPT/UEFI] and [MBR/BIOS or UEFI] scheme. Please note that Rufus offered to choose between different image writing modes (ISO Image or DD Image), I tried both without any joy.

Booting in UEFI mode, installation gets as far as first menu where I choose from 'run without installing', 'install', etc. After selecting 'install' PC crashes - nothing but black screen. After 'run without installing' sometimes I see message 'AHCI mode unavailable' and crash, most of times PC just crashes.

USB created by https://unetbootin.github.io/ is not recognized as UEFI and attempts to boot ends up with 'No operation system found' message.

Created boot USB with Etcher. Installation silently crashes, run without installing stops after displaying USB and AHCI errors. Installation from mini disk freezes on 'Detecting hardware' screen.

Double checked BIOS and can confirm that SATA switched to UEFI mode.

Is my hardware not compatible or I keep doing some mistakes?

Thank you in advance for suggestions

  • SATA mode should be AHCI for sure - RAID modes are often non compatible and IDE is old (for PATA drives) and under-performs - but that is independent of the "boot mode" (UEFI vs BIOS/CSM/Legacy). Yes, you should boot and install in UEFI mode and yes, you should set the SATA mode to AHCI and, if you have an additional graphics cards you may need nomodeset. That's all. – user880592 Oct 22 '18 at 12:00
  • Thank you @GabrielaGarcia, so I meet all requirements but installation does not start from USB. The question is - why? – Andriy Oct 22 '18 at 12:21
  • How did you made that USB? – user880592 Oct 22 '18 at 12:22
  • @GabrielaGarcia, Rufus from Windows, it's in the question – Andriy Oct 22 '18 at 12:24
  • The typical mistake with Rufus is not selecting the correct GPT/UEFI option before burning the ISO, the default being the option for BIOS. Do you remember selecting the correct option? – user880592 Oct 22 '18 at 12:28
0

The issue was resolved by connecting SATA DVD-ROM to a different SATA controller.

In the previous configuration DVD-ROM was connected to ASMedia SATA port, now it's connected to Z77 SATA. Apparently Ubuntu (and other Linux distros I've tried: openSUSE, CentOS) refused to boot with previous connection configuration. Windows (7, 10) had no obvious problems with old configuration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.