1

On a system76 laptop, running Ubuntu 18.04.01 LTS

Wireless has been working fine for a while, but now has slowed to a halt.

Network is fine and working for my iPhone. Am currently using USB (Ethernet) hotspot to try to research and post this question.

Have tried what I know without help:

  • sudo service network-manager restart
  • restarting laptop
  • restarting router and wifi

I don't really know what to do at this point, so any and all help would be appreciated.

Thanks!

Other Info

Here's some additional info from system commands that seemed useful for debugging these sorts of issues. Please let me know if any other info is useful.

Output from sudo lshw -C network

*-network                 
   description: Ethernet interface
   product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0.1
   bus info: pci@0000:02:00.1
   logical name: enp2s0f1
   version: 12
   serial: 80:fa:5b:53:54:5e
   size: 10Mbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8411-2_0.0.1 07/08/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
   resources: irq:16 ioport:e000(size=256) memory:df214000-df214fff memory:df210000-df213fff
*-network
   description: Wireless interface
   product: Wireless 8265 / 8275
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlp3s0
   version: 78
   serial: 74:e5:f9:44:be:1b
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=4.15.0-36-generic firmware=34.0.1 ip=192.168.1.202 latency=0 link=yes multicast=yes wireless=IEEE 802.11
   resources: irq:135 memory:df100000-df101fff
*-network
   description: Ethernet interface
   physical id: 1
   bus info: usb@1:11
   logical name: eth0
   serial: 42:4d:7f:ee:ba:40
   capabilities: ethernet physical
   configuration: broadcast=yes driver=ipheth ip=172.20.10.4 link=yes multicast=yes```

Output from dmesg | grep iwlwifi

[    3.690319] iwlwifi 0000:03:00.0: enabling device (0000 -> 0002)
[    3.695795] iwlwifi 0000:03:00.0: loaded firmware version 34.0.1 op_mode iwlmvm
[    3.724214] iwlwifi 0000:03:00.0: Detected Intel(R) Dual Band Wireless AC 8265, REV=0x230
[    3.780293] iwlwifi 0000:03:00.0: base HW address: 74:e5:f9:44:be:1b
[    3.858610] iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0
0

After realizing my wireless worked on other networks, but not my home wifi, I performed the 30-30-30 factory reset on my wifi router, and everything worked again (both before and after reconfiguring the name/password).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.