1

today I have installed opencv project on my ubuntu, using this tutorial : https://www.pyimagesearch.com/2016/10/24/ubuntu-16-04-how-to-install-opencv/

For some reason, the wifi connection stopped working after the OpenCV installation. The wifi works perfectly fine on my windows 10.

I have tried restaring the network services and look for similar issues, but did not find something useful.

Here are some details from the console :

nmcli con up id "network name"

Error: Connection activation failed.

uname -a

Linux alex-PORTEGE-Z30-A 4.15.0-36-generic #39~16.04.1-Ubuntu SMP Tue Sep 25 08:59:23 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

sudo lshw -class network

*-network               
   description: Ethernet interface
   product: Ethernet Connection I218-V
   vendor: Intel Corporation
   physical id: 19
   bus info: pci@0000:00:19.0
   logical name: enp0s25
   version: 04
   serial: b8:6b:23:b3:c8:79
   capacity: 1Gbit/s
   width: 32 bits
   clock: 33MHz
   capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=0.6-4 latency=0 link=no multicast=yes port=twisted pair
   resources: irq:43 memory:f0600000-f061ffff memory:f063d000-f063dfff ioport:3080(size=32)
*-network
   description: Wireless interface
   product: Wireless 3160
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: wlp2s0
   version: 83
   serial: a0:88:69:b7:e2:ce
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=4.15.0-36-generic firmware=17.948900127.0 latency=0 link=yes multicast=yes wireless=IEEE 802.11
   resources: irq:46 memory:f0400000-f0401fff
*-network DISABLED
   description: Ethernet interface
   physical id: 3
   logical name: wwp0s20u4c2i12
   serial: fa:55:7b:fc:98:02
   capabilities: ethernet physical
   configuration: broadcast=yes driver=cdc_mbim driverversion=22-Aug-2005 firmware=CDC MBIM link=no multicast=yes

I wish I knew where to find more detailed logs about this issue.

dmesg

    [   86.071062] audit: type=1400 audit(1540151189.505:30): apparmor="DENIED" operation="open" profile="/usr/lib/NetworkManager/nm-dhcp-helper" name="/usr/local/lib/libz.so.1.2.9" pid=2201 comm="nm-dhcp-helper" requested_mask="r" denied_mask="r" fsuid=0 ouid=0
[  130.028306] wlp2s0: deauthenticating from b4:ee:b4:ad:76:fc by local choice (Reason: 3=DEAUTH_LEAVING)
[  132.802271] wlp2s0: authenticate with b4:ee:b4:ad:76:fc
[  132.806612] wlp2s0: send auth to b4:ee:b4:ad:76:fc (try 1/3)
[  132.809214] wlp2s0: authenticated
[  132.812093] wlp2s0: associate with b4:ee:b4:ad:76:fc (try 1/3)
[  132.835518] wlp2s0: RX AssocResp from b4:ee:b4:ad:76:fc (capab=0x1411 status=0 aid=1)
[  132.836872] wlp2s0: associated
[  132.877704] audit: type=1400 audit(1540151236.313:31): apparmor="DENIED" operation="open" profile="/usr/lib/NetworkManager/nm-dhcp-helper" name="/usr/local/lib/libz.so.1.2.9" pid=2245 comm="nm-dhcp-helper" requested_mask="r" denied_mask="r" fsuid=0 ouid=0
[  133.901403] audit: type=1400 audit(1540151237.337:32): apparmor="DENIED" operation="open" profile="/usr/lib/NetworkManager/nm-dhcp-helper" name="/usr/local/lib/libz.so.1.2.9" pid=2246 comm="nm-dhcp-helper" requested_mask="r" denied_mask="r" fsuid=0 ouid=0
[  178.054578] wlp2s0: deauthenticating from b4:ee:b4:ad:76:fc by local choice (Reason: 3=DEAUTH_LEAVING)
[  180.694133] wlp2s0: authenticate with b4:ee:b4:ad:76:fc
[  180.698639] wlp2s0: send auth to b4:ee:b4:ad:76:fc (try 1/3)
[  180.701431] wlp2s0: authenticated
[  180.704127] wlp2s0: associate with b4:ee:b4:ad:76:fc (try 1/3)
[  180.707641] wlp2s0: RX AssocResp from b4:ee:b4:ad:76:fc (capab=0x1411 status=0 aid=1)
[  180.717145] wlp2s0: associated
[  180.776754] audit: type=1400 audit(1540151284.213:33): apparmor="DENIED" operation="open" profile="/usr/lib/NetworkManager/nm-dhcp-helper" name="/usr/local/lib/libz.so.1.2.9" pid=2276 comm="nm-dhcp-helper" requested_mask="r" denied_mask="r" fsuid=0 ouid=0
[  181.801668] audit: type=1400 audit(1540151285.237:34): apparmor="DENIED" operation="open" profile="/usr/lib/NetworkManager/nm-dhcp-helper" name="/usr/local/lib/libz.so.1.2.9" pid=2278 comm="nm-dhcp-helper" requested_mask="r" denied_mask="r" fsuid=0 ouid=0
[  226.034090] wlp2s0: deauthenticating from b4:ee:b4:ad:76:fc by local choice (Reason: 3=DEAUTH_LEAVING)

At some point during the installation of opencv, I have resinstalled this library libz.so.1.2.9 - using the accepted answer from this thread https://stackoverflow.com/questions/48306849/lib-x86-64-linux-gnu-libz-so-1-version-zlib-1-2-9-not-found?rq=1

1

0

You must log in to answer this question.

Browse other questions tagged .