2

I use mp3fs on a samba share (openmediavault). When I copy from that mp3fs mountpoint on the share (via terminal or via file manager) usually the process fails at some point thereby crashing the mount point. I have to SSH into the share and unmount and re-mount the mp3fs mountpoint. My fstab looks like this:

mp3fs#/sharedfolders/RAID6/Musik /sharedfolders/RAID6/mp3ben192 fuse allow_other,ro,bitrate=192 0 0

Copying the files from the mp3fs to another directory on the share itself (via terminal and SSH) works fine. So it has to be a problem of the combination of mp3fs and cifs/samba.

The error I get when copying via samba is permission related and in German

Fehler beim Öffnen der Datei »/home/ben/Benshare/OMV/mp3ben192/foo.mp3«: Keine Berechtigung

(translated by me):

Failure to open file "/home/ben/Benshare/OMV/mp3ben192/foo.mp3": no permission

There was also this error this time (not the last time) I did try to do this:

Fehler beim Zusammenfügen der Datei: Eingabe-/Ausgabefehler

my translation:

Failure to put together the file: input-/output error

This second error now came directly after trying to copy in file manager. The last 10 times I tried to copy the exact same files it did not came up but went through 50% of the files and then just gave the first error.

This is a openmediavault RAID 5.

I have tried a lot of options of cifs.mount to make sure it is not related to the way I mount the samba. I now make a forceuser in the smb.conf on the share so I am pretty sure that the right user is used to read the files, but even with guest mode it would fail.

It is important to notice that it does not fail with all files, but just certain ones. All files have the same permissions, user and group of course.

Last 100 lines of syslog give some hints:

Oct 21 19:55:04 OMV mp3fs: FLAC error: FLAC__STREAM_DECODER_ERROR_STATUS_FRAME_CRC_MISMATCH
Oct 21 19:55:04 OMV mp3fs: FLAC error: FLAC__STREAM_DECODER_ERROR_STATUS_BAD_HEADER
Oct 21 19:55:04 OMV mp3fs: FLAC error: FLAC__STREAM_DECODER_ERROR_STATUS_LOST_SYNC
Oct 21 19:55:04 OMV kernel: [98294.016566] mp3fs[32546]: segfault at 7f2578c7d000 ip 00007f257af01344 sp 00007f2578c72240 error 4 in libmp3lame.so.0.0.0[7f257aee5000+47000]
2

Main 2 reasons:

  • hardware error
  • firmware/driver error

Errors regarding mounting should report those issues to /var/log/. So have a look there when it happens.

To list log files in order of time changed in reverse order:

ls -ltr /var/log/

and check the log that looks like an error log for the last few lines with

tail -n 100 /var/log/syslog

(Assuming it was syslog listed last)

The error I get when copying via samba is permission related.

It is custom to add the actual command and error into the question. Please do and I might be able to expand the answer.

Also important to check: have a look at the issues list on github.

--

It is a bug in the driver regarding FLAC. See this related issue. I would advice to create a topic there and include the file it happens with as asked in the previous link (but was not answered).

  • Thanks a lot! I added error messages but more importantly, I added syslog messages at the bottom. – Ben Oct 21 '18 at 18:05
  • 1
    It is a bug in the driver regarding FLAC. See the link I added. – Rinzwind Oct 21 '18 at 18:47
  • I actually read this once but could not make a connection because I did not know about the log. I uploaded a file there. – Ben Oct 21 '18 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.