Using my touchpad on my Unity desktop I have discovered the following:

Tapping the corners of the touchpad results in:

  • Top-right corner: Paste command.
  • Top-left corner: Copy command.
  • Bottom-right corner: Right-click or Context Menu commands.

Obviously, it's intentional however there must be settings to change these. I've looked through Settings->Mouse & Compiz Settings Manager but failed to find anything.

How do I disable these triggers?

  • 1
    funny... in reading your question you solved another problem I had, which is: "how to mimic the middle click button on a touchpad without buttons". I used to be addicted to left+right click on my previous laptop (Asus N55) and got stuck with the "all flat" touch pad of my new one (HP ProBook). Thanks! – Andrea Borga Feb 11 at 22:47

In terminal, type: synclient RTCornerButton=0. This solved the problem on me.

Execute synclient -l to list all configurations.

  • 1
    Note that this only disables the paste feature (note the RT). Repeat this step for RBCornerButton, LTCornerButton and LBCornerButton to disable the other functions. Note that this setting does not appear to persist on a reboot according to this. – Wk_of_Angmar Oct 16 '14 at 20:40

Any changes you make with synclient are lost after reboot. To make the solution posted by Cyron permanent, paste the synclient command(s) to a shell script and add the shell script to your Startup Applications in Unity.

Note that the script has to start with #!/bin/bash, and that you may change permissions to executable to work properly.

  • Although I can create a shell script of it just fine, it should be noted that autostarting it with the computer doesn't seem to work in Xubuntu 17.04 (the settings must be reset after the script launches). However, having the script sleep for a little while before the script executes fixes it. – Shule Sep 11 '17 at 14:35
  • @Shule I ve been trying to do the same for 16.04 and 17.10. Can you share the script? – Ekoji Mar 31 at 6:25
  • @Ekoji Sure. I found a way to disable it with startup, too (just make it sleep for a while before execution). Here's the first script (which is just for toggling the left-click): pastebin.com/aNiWesUb and here's the one to use at startup: pastebin.com/pkXRJCxg You can treat them both as if they were public domain. You may need to edit some of those. – Shule Apr 1 at 5:19

I was looking to solve this problem as well. I don't use a mouse; I use touchpad exclusively. My preferred code editor is vim and I was fed up with unintentional copy and pasting while touching the corners of my touchpad. It seems solution is easy:

  1. Go to Applications -> System Tools -> System Settings
  2. Click on Mouse and Touchpad option.
  3. Click to open the Touchpad tab.
  4. Uncheck "Enable mouse clicks with touchpad" option.

That's all! Enjoy.

  • 1
    This would disable even left click with touchpad, not a good solution. – theharshest Sep 28 '13 at 9:43
  • Yes, this actually deservers a down click. But since I've got a few of those haunting me for what I considered to be good answers, I won't do it to you. – Dennis Apr 2 '14 at 5:47
  • Although I personally have found disabling tapping with the touchpad to be quite a stress reliever (after tapping with the touchpad ever since I've begun using touchpads, until recently), this does not do anything besides disable the left-click feature (on my Dell Inspiron 3520 with Xubuntu 17.04 64-bit on it). I can still right-click, copy, and paste from the touchpad. I say it's a stress reliever because it prevents accidental clicks (which prevention is very nice when programming to avoid distractions, or even surfing the web, to prevent accidentally clicking on ads). – Shule Sep 11 '17 at 13:51

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.