1

sudo apt-get install r-base

sudo: unable to resolve host dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 r-base : Depends: r-base-core (>= 3.4.4-1xenial0) but it is not going to be installed
          Depends: r-recommended (= 3.4.4-1xenial0) but it is not going to be installed
          Recommends: r-base-html but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I want to install r in my ubuntu 16.04.

please HELP ME!!!

0

When I've seen messages like "Depends: r-base-core (>= 3.4.4-1xenial0)" it has meant that the required package r-base-core exists, but it is down-level (version less than 3.4.4-1) so it can't be used. Check in your package manager and see what version of those packages are available. You won't be able to install r-base unless all the dependencies can be met. An option may be to download the source and compile it yourself, but that could mean you need a bunch of development packages, so you'd need to work through that. I've just looked on my Ubuntu 18.04 laptop and r is at 3.4.4-1 according to my Synaptic package manager. Ubuntu 18.10 has version 3.5.1-1. You could try upgrading Ubuntu. I upgraded from 16.04 to 18.04 a while back and it was trouble free. If you try that, make sure to have a good backup first. I don't know about going from 16.04 to 18.10.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.