0

I reinstalled my Kubuntu 18.04 system 3 weeks ago. I have installed updates in the last few days, then the internet speed has dropped significantly. Instead of 250/20 Mbit, only 20/15 Mbit can be measured. For USB Live system does not have this phenomenon.

On the live system, the 4.15.0-20-generic kernel runs while the currently installed 4.15.0-36-generic kernel is running, trying to boot with the older kernel in GRUB, but the situation did not change

uname -a: (live) Linux kubuntu 4.15.0-20-generic #21-Ubuntu SMP Tue Apr 24 06:16:15 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

uname -a: (installed) Linux adam-desktop 4.15.0-36-generic #39-Ubuntu SMP Mon Sep 24 16:19:09 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Config:

Motherboard: Asrock 960GM-GS3 FX
CPU: AMD Athlon II X2 250 3.00GHz AM3
NIC: TP-Link TG-3269 (Realtek RTL-8169SC chip)
0

Same problem on two my devices with Kubuntu 18.04. In my case, speed has dropped from 100/100 Mbit to 10/100 Mbit. Execute command ethtool -s <my_interface> autoneg on speed 100 duplex full resolve this. Before, auto-negotiation is off and duplex is half, changing NetworkManager settings has no effect on ethtool output and speed. Before:

Settings for enx00e04c3605cc:
Supported ports: [ TP MII ]
Supported link modes:   10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
Supported pause frame use: No
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes:  Not reported
Advertised pause frame use: No
Advertised auto-negotiation: No
Advertised FEC modes: Not reported
Speed: 100Mb/s
Duplex: Half
Port: MII
PHYAD: 32
Transceiver: internal
Auto-negotiation: off
Cannot get wake-on-lan settings: Operation not permitted
    Current message level: 0x00007fff (32767)
                   drv probe link timer ifdown ifup rx_err tx_err tx_queued intr tx_done rx_status pktdata hw wol
    Link detected: yes

After:

Settings for enx00e04c3605cc:
Supported ports: [ TP MII ]
Supported link modes:   10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
Supported pause frame use: No
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes:  10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                     100baseT/Half 100baseT/Full 
Link partner advertised pause frame use: Symmetric
Link partner advertised auto-negotiation: Yes
Link partner advertised FEC modes: Not reported
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 32
Transceiver: internal
Auto-negotiation: on

Cannot get wake-on-lan settings: Operation not permitted    Current message level: 0x00007fff (32767)
                   drv probe link timer ifdown ifup rx_err tx_err tx_queued intr tx_done rx_status pktdata hw wol   Link detected: yes
  • I have full duplex 1000 but speed in 50-100Mbit/s sudo ethtool enp2s6 Settings for enp2s6: Supported ports: [ TP MII ] Supported link modes: 10baseT/Half 10baseT/Full 100baseT/Half 100baseT/Full 1000baseT/Half 1000baseT/Full ... Advertised link modes: 1000baseT/Full Advertised pause frame use: Symmetric Receive-only ... Link partner advertised link modes: 10baseT/Half 10baseT/Full 100baseT/Half 100baseT/Full 1000baseT/Half 1000baseT/Full Link partner advertised pause frame use: Symmetric Receive-only ... Speed: 1000Mb/s Duplex: Full Port: MII ... – Adam P. Oct 27 '18 at 14:03
  • I think I will reinstall and block the kernel update soon, I hope to solve the problem. – Adam P. Oct 27 '18 at 14:04

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.