I want to install the latest updates of Ubuntu in my laptop, but while clicking on show updates... It is throwing a The package system is broken error, and it is asking me to disable the third party repositories.

I tried unchecked the third party repositories in the Other software tab in Software & Updates, but I am unable to disable them.

Now how to disable the third party repositories? Without disabling, it is not allowing me to install the latest updates.

I am facing the below error

=================================
Check if you are using third party repositories. If so disable them, since they are a common source of problems.
Furthermore run the following command in a Terminal: apt-get install -f
Transaction failed: The package system is broken
 The following packages have unmet dependencies:

virtualbox-5.2:i386: Depends: libcurl3 (>= 7.16.2) but 7.47.0-1ubuntu2.9 is installed
                     Depends: libdevmapper1.02.1 (>= 2:1.02.97) but 2:1.02.110-1ubuntu10 is installed
                     Depends: libgcc1 (>= 1:4.2) but 1:6.0.1-0ubuntu1 is installed
                     Depends: libice6 (>= 1:1.0.0) but 2:1.0.9-1 is installed
                     Depends: libsdl1.2debian (>= 1.2.11) but it is not installed
                     Depends: zlib1g (>= 1:1.1.4) but 1:1.2.8.dfsg-2ubuntu4.1 is installed
=================================
  • 1
    Welcome to Ask Ubuntu! Could you please edit your question to include the output of sudo apt-get update; sudo apt-get dist-upgrade -f? Thanks. – David Foerster Oct 21 at 12:03
  • @heynnema: I know. apt-get dist-upgrade doesn’t perform release upgrades in case you’re confused. – David Foerster Oct 21 at 13:48
  • Please see my answer. Please remember to accept it if it was helpful. Thanks! – heynnema Oct 24 at 14:20

To workaround the problem (bug) of not being able to select/deselect repositories in Software & Updates, open Synaptic, enter your password, then select Repositories from the Settings menu.

But wait... do this first. In Synaptic, go to the Edit menu and select Fix Broken Packages. Do this twice. Then click the Reload icon, and if any errors appear, you need to fix those, to help solve your problem.

Once done, you probably won't need to disable repos, and you can continue with your Software Updater app.

Also, I'm guessing that you have a 64-bit computer, and virtualbox-5.2:i386 would be the wrong version of VB. You probably need to uninstall this version and install the 64-bit version. You can use Synaptic to do this.

  1. You can remove a software source in Software & Updates by selecting the software source in the Other software tab, clicking the software source which you want to remove, and clicking the Remove button.

  2. After clicking the Remove button in the Other software tab in Software & Updates a new small Authentication Required window opens up that looks like this. Type your user password and click the Authenticate button.

    enter image description here

  3. A new small window opens up with a Reload button that refreshes the list of available software. The Reload button is marked by the mouse cursor in the below screenshot. Maybe you didn't click the Reload button, so your list of available software did not get updated, and as a result the package system is broken.

    enter image description here

    The information about available software is out-of-date 
    
    To install software and updates from newly added or changed sources,  
    you have to reload the information about available software.
    
    You need a working internet connection to continue.

    Clicking the Reload button in Software & Updates does the same thing as running sudo apt update in the terminal.


After that you can download the VirtualBox .deb file for Ubuntu 16.04 from the official Oracle website and double-click the .deb file to install it, or follow the instructions for adding the Oracle VirtualBox repository to your software sources at the Oracle VM VirtualBox virtualbox.org webpage. Installing VirtualBox using the second option allows VirtualBox to be updated automatically, but this feature is not necessary because if you install VirtualBox using the first option you will be prompted in the VirtualBox application to update it to the latest version when an update is available.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.