1

I upgraded to 18.10. Now I have a problem with apt. It seems to be a problem with the sendmail-base package:

sudo apt autoremove 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up sendmail-base (8.15.2-11) ...
Saving current /etc/mail/sendmail.mc,cf to /var/backups
update-inetd: warning: cannot add service, /etc/inetd.conf does not exist
update-inetd: warning: cannot add service, /etc/inetd.conf does not exist
update-inetd: warning: cannot add service, /etc/inetd.conf does not exist
update-inetd: error: --group is only relevant with --add
dpkg: error processing package sendmail-base (--configure):
 installed sendmail-base package post-installation script subprocess returned error exit status 255
Errors were encountered while processing:
 sendmail-base
E: Sub-process /usr/bin/dpkg returned an error code (1)
sudo apt remove sendmail-base
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  sendmail-base
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 867 kB disk space will be freed.
Do you want to continue? [Y/n] 
(Reading database ... 650513 files and directories currently installed.)
Removing sendmail-base (8.15.2-11) ...
update-inetd: error: --group is only relevant with --add
dpkg: error processing package sendmail-base (--remove):
 installed sendmail-base package pre-removal script subprocess returned error exit status 255
Errors were encountered while processing:
 sendmail-base
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • 1
    I found a forum where they tell me to change a line in the deb file. But I don't konw how to do this – Boba Fit Oct 21 '18 at 11:12
  • I have the same problem exactly... How did you fix this? – lonix Oct 23 '18 at 8:12
  • I "cheated" my system a bit. Then the remove worked, but i got havier problems with dpkg. – Boba Fit Oct 23 '18 at 11:05
  • I tried installing postfix but that didnt help, then a null MTA and that didnt help... – lonix Oct 23 '18 at 12:57
  • 1
    I followed advice in that link you provided to edit prerm file and managed to uninstall sendmail-base and sendmail-bin and now everything works. Thanks. – lonix Oct 24 '18 at 6:27
1

I had similar errors: update-inetd: error: --group is only relevant with --add.

So I followed advice in the link OP gave above.

I did this:

  • edited sendmail's pre-removal script /var/lib/dpkg/info/sendmail-base.prerm accordingly (depends on the error you're getting) ...I removed --group MAIL from that problem line, was almost at the top of the file
  • uninstalled sendmail-base and sendmail-bin (though this may be unnecessary... I had so many errors relate to sendmail that I just nuked it... don't need it on my ubuntu desktop anyway)
  • installed lsb-invalid-mta which is a fake MTA (will avoid problems later on with apps that want an MTA) - only necessary if sendmail was removed above

Now apt is upgrading properly again!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.