I have dual boot with Windows 10 and Ubuntu 18.04 on my machine.

When I select Ubuntu on the boot screen, firstly it seems to turn out fine. But then it gets stuck on Ubuntu load screen (the purple one, with the Ubuntu logo). Apparently, going through different forums, there is some difference of up until which dot the screen loads - in my case, it is up until the last one. The screen was frozen for 12 hours before I tried a different method. Also tried going into recovery mode and running dpkg to fix packages, but when I try to reboot (with the option given) in recovery mode, it gets stuck on "Started update UTMP about System Runlevel Changes".

I have a VAIO SVF15 8GB with an Nvidia Graphics Card.

Obs.: On and off it happens that Ubuntu won't load for some reason. Most times I can proceed with the solutions from several forums but sometimes my case doesn't seem to be contemplated by any of them (they don't work). In those cases I am forced to create a liveUSB, format my partition and reinstall Ubuntu. This happens every once in two weeks and it's been really frustrating having to keep putting all the work I've done in the day to a flash drive out of fear this will happen again and I won't be able to get it back.

I use Ubuntu on a daily basis, and it works fine. There have been times when I boot into Windows 10 and then try to boot back into Ubuntu, it doesn't boot (which is this case). And then when my Ubuntu screen freezes, when I force restart, it doesn't boot also.

  • I don't think it has anything to do with dual boot. Can you check the dmesg output after command line login ?
    – user1868
    Oct 22, 2018 at 13:27

2 Answers 2


This may or may not be your problem, but it's worth checking. I had a dual boot Ubuntu and Windows problem that no one could solve but I worked out from days of reading things on and off...

You cannot boot from an MBR formatted drive into an operating system that is on a GPT formatted drive.

Without going through the technical details; the simple answer is to avoid this situation any way you can.

For example, large drives (over 2TB) will certainly be GPT formatted, and it will make sense to make a partition there and install an operating system on it, because it probably has the most room.

But if you have an older computer setup with a hodge-podge of drives installed (like me) it's likely the older drives are still formatted as MBR, since this what Windows will default to (Windows 7 at least - I can't speak for Windows 10)

So when you go to do a dual boot set up - everything will appear fine, and Ubuntu's dual boot set up will not warn you about this. (Windows avoids this situation completely by way of just not supporting dual boot in its setup...)

But then when you reboot, the GPT drive is not yet available at the point the computer boots from the MBR, and so the boot info points to a location on a GPT drive that doesn't exist yet, and the computer just doesn't even boot - you get a GRUB error about not finding a partition.

THE SOLUTION IS: use Windows Disk Management, or Linux Gparted to identify which drives are MBR and which drives are GPT. Make use of the available space on the GPT drive by moving files from an MBR drive onto that GPT drive, to make room for your Linux operating system partition. Then you can install Linux to that MBR drive and you will avoid that problem completely.

(I know I skipped over how to determine if a drive is MBR or GPT but let me know if you need it and I'll update my answer.)

  • I don't believe this to be the case since I've booted to Ubuntu before and, when it failed to boot, I was able to solve it. Always with dual boot.
    – DrHAL
    Oct 21, 2018 at 7:37
  • Also, if my computer recognizes the Ubuntu load screen, isn't the problem different? From what I read of your answer, my computer shouldn't even recognize the Ubuntu OS.
    – DrHAL
    Oct 21, 2018 at 7:50
  • Yes fair enough, I figured it was worth mentioning just in case.
    – Domarius
    Oct 21, 2018 at 8:27

Ever try another option (kernel version) in "advance option" in the boot grub menu? Yesterday i just found my system can't boot, and worked after select older version of kernel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.