0

Upgraded from 18.04 to 18.10. All worked well until I shut down. Now when I boot up, I get the login loop. Enter passphrase and go back to main login screen.

I did the CTRL+ALT+F3 and find that my /home/steve folder contains only one directory and 4 linked files.

I also see just after the command line login the message "mount: Bad address"

I tried sudo ecryptfs-recover-private It found /home/.ecryptfs/steve/.Private

I entered the login passphrase and see this series of messages:

Inserted auth tok with sig [193135fb7689a807] into user session keyring
mount: /tmp/ecryptfs.skNK9k22: mount(2) system call failed: Bad adderss.  
ERROR: Failed to mount private data at [/tmp/ecryptfs.skNK9k22]

That directory does exist in /tmp with privs drwk------ for root root

folder ecryhptfs.skNK9k22 contains only the . and .. directories.

0

It looks like the passphrase is correct, since the recovery script "Inserted auth tok with sig [193135fb7689a807] into user session keyring" OK.

There's few results now when searching for mount (2) "system call failed: bad address", but this bug report involves upgrading from 18.04.1 to 18.10 also, and a thread on Ubuntu forums and they can't seem to mount anything even in a terminal. If you're not able to mount anything either, it's looking like a bug in the upgrade somehow, or at least something wrong with the upgrade & eCryptfs.

To recover (or at least backup) your home files, I would:

  1. Boot a live ISO of Ubuntu 18.04 (but trying a live 18.10 might work too, in case it's only an upgrade related problem)
  2. Run ecryptfs-recover-private on your mounted home partition, mounting/decrypting your home files
  3. Copy/backup your files so they're at least safe

Then, in your main 18.10 install, I'd try creating a new user with an encrypted home, verify that they can log out & in successfully, and delete & re-create your main user & copy your backed up home files to your new home.

  • I now have a live ISO of 18.04 running. Had to install ecryptfs-utils and now step 2 can't find a directory to decrypt. Researching to see if I can point it to the mount point on /media – Steve Butler Oct 22 '18 at 2:25
  • It should be on your old home partition, as long as it's mounted and readable (probably have to run the recover-private program as root iirc). I think it's in home/.ecryptfs/username, not the home/username (that gets used when it's decrypted/mounted normally) – Xen2050 Oct 22 '18 at 3:39
0

Have you tried 'login' from the root shell? I believe I am experiencing the same issue, or at least the same symptoms, and was able to login from the root shell to access my user data decrypted.

  • That also gave me a "bad address" for the mount. After poking at it with the 18.04 live ISO, finally told me that it was configured wrong. I gave up and am rebuilding the box. The user folder was backed up to Windows -- now to just get it all hooked up again! – Steve Butler Oct 22 '18 at 4:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.