9

I upgraded my VMware Ubuntu 18.04 to 18.10. After the upgrade it was working fine until I shutdown and restarted the VM, and now it won't display in full screen.

I followed by installing a fresh copy of 18.10 and at first it was working fine right after install and after reboot the same thing happened.

Any suggestions?

27

I ran into the same issue on a fresh install of 18.10 on VMWare 15.01. If I manually restarted open-vm-tools after I logged in, everything worked. I tried to reinstall VMWare tools, it didn't help. This did fix it:

Edit this file using your preferred editing tool

/etc/systemd/system/multi-user.target.wants/open-vm-tools.service

Add these lines to the end of the "Unit" section

Requires=graphical.target
After=graphical.target

Save the file and the next time you restart you should be good to go.

You can apply the changes immediately without restarting by running

sudo systemctl daemon-reload
sudo service open-vm-tools restart
  • Worked for me as well for Ubuntu 18.04 after some upgrade. – Guy Avraham Mar 18 '19 at 17:46
  • Works for me. Win10 + VMware WS 15 Player + ubuntu-18.04.2-desktop-amd64 – jahackbeth Mar 29 '19 at 4:21
1

Create a text file with .sh extension. For example setscreen.sh

Insert the following text and save.

xrandr --newmode "1920x1080"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr --addmode Virtual1 1920x1080
xrandr --output Virtual1 --mode 1920x1080

Run this .sh file as an executable. Screen should go to 1920x1080.

Use "startup applications" to launch the file at startup.

0

go to settings > display > specify monitor settings.Then choose the right resolution for your computer.

0

See here: https://github.com/vmware/open-vm-tools/issues/303

Requires an edit to Unit section of open-vm-tools

After=graphical.target

0

Just add the sudo service open-vm-tools restart as command in "Startup Applications", to make it run after system starts.

0

Delaying the service open-vm-tools to start after the display manager and it seems to work.

~$ sudo vi /lib/systemd/system/open-vm-tools.service

Add under [Unit] the following line:

After=display-manager.service

Reference https://communities.vmware.com/thread/576221

Save the file and reboot. The screen should be able to fit as needed.

Not the answer you're looking for? Browse other questions tagged or ask your own question.