4

I have AMD RADEON graphics in my laptop. As I was using windows 10, I had inbuilt as well as third party softwares for switching between intel and Amd graphics for different applications/games. Is there similar software available for Ubuntu? Even Amd website is not giving proper software for switching for Ubuntu as it was giving Crismon tool on windows. Amd Switchable Graphics

5

All you have to do is add DRI_PRIME=1 before the command of whatever you want to run using your dedicated Radeon GPU, so for example you can run Steam using DRI_PRIME=1 steam, and all of you games should use the Dedicated GPU.

If that does not work, then you might need to install switcheroo-control (I had to do that too) using sudo apt install switcheroo-control. This will also add an option to run using dedicated GPU from the right-click drop down menu in GNOME, so for example you can choose the dedicated GPU for Steam from the application menu > right-click Steam > "Launch using Dedicated Graphics Card":

dedicated GPU option in GNOME

If your steam games still use the integrated GPU after all of that (which they shouldn't), then you might need to enter DRI_PRIME=1 %command% to each game in their Launch Options. More on that here.

6
  • I don't understand your answer. I'm on Ubuntu 18.04.4 LTS on a HP G72 w/ Intel/Radeon (HD 5430/5450/5470) setup. First, what do you mean by DRI_PRIME=1 ? Do you mean it must be added to the command line ? For instance firefox DRI_PRIME=1 ? Then, I tried to use switcheroo-control, but to no avail. I installed it with apt, but nothing changed, no added option in favorite dock (right-side of the screen application icons). Do I need to reboot, change some config file, or anything else ? Thanks for any hint ^-^ – Mutos Jul 12 '20 at 15:14
  • 1
    The command need to be prefixed by DRI_PRIME=1 !!!! For instance, if you want to run glxgears with the dedicated graphics (AMD or NVidia depending on the machine) instead of the integrated one (usually Intel), type : DRI_PRIME=1 glxgears – Mutos Jul 12 '20 at 15:55
  • 1
    Thanks Tooniis for this answer, I've been trying to use my dGPU for months to no avail and now it works ! However, it took me nearly one hour to figure that DRI_PRIME was a kind of directive to be typed before the command ^-^ – Mutos Jul 12 '20 at 16:02
  • @Mutos the example I provided is clear isn't it? Anyway, I edited the answer to make it clearer. – Tooniis Jul 15 '20 at 11:13
  • 1
    Hi Tooniis, now it's very clear with the screenshot ^-^ I now have got the "Launch using dedicated graphics card" item on the menus, for instance freeCAD. And of course, I can launch with DRI_PRIME=1 the most important app, that is, the game I'm TCing ^-^ – Mutos Jul 19 '20 at 15:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.