0

I'm unable to connect to my Redmi Note 5 Pro, I'm on MIUI 10. However I'm able to connect to other devices (One Plus 3T). I tried installing gmtp as suggested here, also tried to change the cable. I also tried to install libmtp from this repo, but nothing works.

I'm getting this error when I try to access my device :

Unable to access "SDM636 MTP SN:E5BA4F65"

PS: I'm able to access the device from Windows 10 in the same laptop, but not in Ubuntu 18.10.

I'm unable to access my device through android studio too. Can anyone suggest me what to do?

5

Install go-mtpfs with

sudo apt-get install go-mtpfs

Create a directory:

sudo mkdir /media/Redmi5

set the ownership of this directory with

sudo chown -R $USER:$USER /media/Redmi5

Then you can mount/unmount this directory with:

Mount:

go-mtpfs /media/Redmi5 & 

Unmount:

fusermount -u /media/Redmi5

You will have to do this every time you want to mount it.
File transfers are extremely slow.

This is the best solution I have found so far.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.