43

I tried to install Ubuntu 18.10 on my XPS 15 9570 earlier. Everything was working fine until I got to the partition selection part of the installation. That's when the installer crashed and I had to shut down my machine. I think it's because I had my SATA configuration set to RAID ON instead of AHCI, which is now fixed.

Now when I try to run the installer from my bootable USB I get the following error

Failed to open \EFI\BOOT\mmx64.efi - Not Found
Failed to load image \EFI\BOOT\mmx64.efi: Not Found
Failed to start MokManager: Not Fond
Something has gone seriously wrong: import_mok_state() failed

Hoping someone might have some idea as to what is going on

46

I booted an Ubuntu Live USB stick, went into my hard disk drive's /boot/efi folder and renamed the file grubx64.efi to mmx64.efi

Reboot the machine and it should work.

  • 4
    2 hours googling before I found this! thanks. – Ivan Meredith Oct 25 '18 at 1:23
  • 1
    This does not help much since the boot drive is read only by default. There are significant hoops to jump through to be able to modify these files. – gnomed Feb 26 at 21:05
  • 2
    @gnomed There is a second FAT partition with the same layout (efi/boot). I managed to boot the USB stick by renaming the file accordingly. – Christian Rauch Mar 12 at 20:40
  • 1
    @joe-meagher How can you do that on a bootable live USB? – tjespe Mar 17 at 14:14
  • I was trying to install Ubuntu 18.10 on my Asus rog g751jt and got the same problem, I create the installer with Universal-USB-Installer-1.9.8.2 on Windows 10, but this was the solution, thank you. – Minichini Fernando Mar 17 at 17:29
14

The problem was that in the bootable USB the file mmx64.efi didn't exist, so the workaround was to copy the file grubx64.efi under the name mmx64.efi (so the USB Drive folder /EFI/BOOT now contains three files: BOOTx64.EFI, grubx64.efi and mmx64.efi). Then, reboot and the installation should work.

I created the USB bootable drive from Windows 10 with Rufus.

The copying can be done using any file editor on the same or another computer, if the default settings have been used in Rufus for the USB drive.

  • well, that's basically what the accepted answer suggested. But copying the file rather than just mv'ing it is almost certainly a better idea... If you want to thank another answer, you can just upvote it (this is recorded even if you don't have enough reputation to impact the score). If you want to improve it, you can suggest an edit. I'm not voting to delete your post, as it might possibly be useful as is. But please try to avoid duplicating information on SE sites by posting similar answers. – Zanna Dec 3 '18 at 16:11
9

The answers here all suggest modifying the file system on the live USB, which isn't really possible without rebuilding the entire ISO image as far as I have understood.

I think the reason my problem, and the OP's problem, occurred was that we checked the box for installing third-party software in the installer, and subsequently checked the box for managing secure boot through MOK as required, but were then unable to finish the installation and left the computer in a state where it was expecting to boot the MOK manager on the next boot with a path that exists in the Ubuntu system, but not on the Live USB.

To solve this I did a strange work around. I followed the instructions for installing Ubuntu through Wubi as provided here, and then, after restarting my computer, Wubi managed to launch the MOK manager and although I didn't perform any MOK management it seems like this stopped the computer from expecting to find a MOK manager on startup, and when I tried to boot from USB afterwards it suddenly worked. Afterwards I just deleted the Wubi install and all the Wubi files and installed Ubuntu the normal way using the Live USB.

I could be wrong about my assumptions in this answer, but after trying several USBs and many different Ubuntu ISO images, this was what finally did the trick.

Note: What I described in this answer requires that you have Windows installed, which you may not. If you don't, you might be able to solve it in a similar way by booting a system that has GRUB and the MOK manager on it.

  • The thing about third-party software is exactly what happend in my case. But note that you do not have to rebuild the ISO image. Once the bootable USB drive is created, you can just edit its contents. – ke. Aug 27 at 20:29
4

I faced the same problem with the same error message when installing Ubuntu 18.04.2 LTS on my Acer Aspire V 17 Nitro Black Edition. The proper solution for me was to turn on secure boot again and to add the \EFI\BOOT\grubx64.efi (located on the Ubuntu installation USB medium) to the trusted .efi list in my BIOS (F2) and turned the secure boot off again. Afterwards I rebooted and called the the boot manager via F12 there I was able to select the trusted efi file. This invoked grub and I just needed to select install Ubuntu to start the installation.

2

I had the same problem. Creating an UEFI-only bootable USB did the trick for me.

Here's the instructions: How to create UEFI-only bootable USB live media?

More information about the UEFI bootable on Ubuntu: https://help.ubuntu.com/community/UEFI

  • 2
    Please edit your answer to include the actual steps to the solution (+ linnks) rather than just links – j-money Mar 27 at 10:07
2

This happens because windows gets a chance to run first, runs its updates and turns on secure boot in the bios. You need to go into bios and turn it off. During ubuntu installation it will ask to turn it on if you install 3rd party drivers.

Windows just Hellen Keller's your BIOS and lets you figure out what it messed up.

1

I ended up installing JackHack96's Ubuntu 18.04 respin for the XPS 15 and then upgrading to 18.10

0

i solved the problem by following this page: https://www.pcwelt.de/ratgeber/So-klappt-der-Multiboot-mit-Windows-Linux-Doppel-OS-9666313.html

Ok, its written in german, so i will translate the part, which solved my problem: in the boot menue, and there the boot options, you have to search for somthing like "CSM"; "Launch CSM"; "UEFI and Legacy". This option has to be enabled. The boot mode has to be on "Auto".

After this, i could boot from ubuntu-cd. but only overwrite the preinstalled windows 10...which wasnt a real lose.

0

For me, the following worked.

  1. Keep the secure boot on

  2. Go to BIOS by pressing F2 during boot, then go to Boot using arrow keys. Click on UEFI Hard Disk Drive BBS Priorities

                 Aptio Setup Utility - Copyright (C) 2014 ...
      Main  Advanced  Chipset  Feature | Boot | Security ...
    ---------------------------------------------------------
      Boot Configuration
    
      Bootup NumLock State  [On]
      Quiet Boot            [Enabled]
    
      Set Boot Priority
      Boot Option #1        [USB Key]
      Boot Option #2        [CD/DVD]
      Boot Option #3        [Hard Disk:ubuntu]
      Boot Option #4        [USB CD/DVD]
      Boot Option #5        [USB Hard Disk]
      Boot Option #6        [Network]
    
    > UEFI Hard Disk Drive BBS Priorities
    
    ---------------------------------------------------------
                 Version 2.15.1236. Copyright (C) 2014 ...
    

    Transcribed from: BIOS screenshot 1

  3. Then, you get to this screen:

                 Aptio Setup Utility - Copyright (C) 2014 ...
                                     | Boot |
    ---------------------------------------------------------
      Boot Option #1        [ubuntu]
      Boot Option #2        [UEFI OS (P0: SAMSUN...]
      Boot Option #3        [ubuntu (P0: SAMSUNG...]
    
    ---------------------------------------------------------
    

    Transcribed from: BIOS screenshot 2

    Here make sure that Boot Option #1 is selected as ubuntu

Note: Not sure if this will create issues if you have dual boot with Windows. In my case, I only have Ubuntu! Also, as suggested by Fransisco, I copied grub64.efi to mmx64.efi to make it boot.

protected by Community May 30 at 10:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.