After the upgrade, the system boots to a blank screen. Cntrl+Alt+F1/F2 doesn't do anything ... but the system is running, I can ssh to it, and ALT+PrtScr+B will trigger a reboot.

Doing an SSH the system does start wayland (it is running), but the screen is blank.

Things I tried:

  • When booting at recovery mode, the screen freezes after a while. I suspect the system is running (since I can do Alt+PrtScr+B to reboot), but something it starts that is not the console is not working -- I can't check since it doesn't start sshd, and I can't login to the machine.

  • Nvidia driver version is 410. But i just tried the 390 as well.

  • I tried starting Xorg manually (/usr/bin/Xorg) from my ssh, and it works. I just run /usr/bin/Xorg (root) and then set DISPLAY=:0.0 and gnome-shell and I get a working Xwindows for rooot.

  • I also tried a newest kernel (4.19-rc8 I think) recommended in another post, but didn't help.

Any suggestions ? Any error messages / files I should be looking at ?

Is there a way to make gdm work with Xorg instead of Xwayland until it works ?

many thanks in advance for any pointers!

ps.: I've seen a bunch of similar questions, but none of the answers seem relevant.

1 Answer 1


After some more digging, I found how to force gdm to use only Xorg:

  • Edit /etc/gdm3/custom.conf
  • Uncomment line with WaylandEnable=false

Now the system is usable again -- albeit without Xwayland.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.