4

Here are the specifications of my laptop:

Xiaomi Mi Notebook Pro (i7-8550U) Laptop Review

  • Processor: Intel Core i7-8550U
  • Graphics adapter: NVIDIA GeForce MX150 - 2048 MB
  • Memory: 16GB DDR4-2400

I have been running it with Ubuntu 16.04, 17.10 and 18.04 with no issues.

I decided to wipe the laptop and install a fresh copy of Ubuntu 18.10.

Now, the laptop freezes after login. I quickly do Ctrl-Alt-T and top to track what's causing the freeze and often see that a process called kworker/6:3+events would jump quickly to 100% CPU, frequently followed up by another kworker process also using 100% CPU.

I am desperate for a solution at this point, and am downloading the 18.04 ISO on my work laptop as I am writing this post.

Any hints?

2
  • @karel no its not, I looked at that thread also and all of the suggestion does not apply to my case. This is a fresh install(minimal installation option even) of Ubuntu on a laptop so there cannot be that much things going on that would take up an i7 core CPU. And i did not have issue with 18.04 so its a 18.10 specific issue – Luong Ngoc Son Oct 20 '18 at 6:12
  • 1
    I rolled back to 18.04 for now without any issue. Hope that this problem will be fixed – Luong Ngoc Son Oct 21 '18 at 9:18
5

Same thing happened to me, turns out it's Nouveau drivers not playing well with the Nvidia MX150. I solved by starting in recovery mode, going to root terminal, and using ubuntu-drivers autoinstall to install Nvidia proprietary drivers.

5
  • Does this happen to you from a fresh install or was it an upgrade from 18.04? – Luong Ngoc Son Oct 23 '18 at 1:46
  • This worked for me on my Xiaomi Mi Notebook Air i7-8550U thx. – LayerCake Oct 24 '18 at 18:18
  • After a few hours of testing this only partialy fixed the problem. Now I get a "Send Error Report" dialog on each boot containing something about kworker. Still, the system is running so better than before. – LayerCake Oct 24 '18 at 20:49
  • This was on a fresh install. I haven't had any trouble since. – Sean Malseed Oct 25 '18 at 19:57
  • Installing the Nvidia drivers works, but I suggest tying the alternative solution using modprobe.blacklist=nouveau first. – PJ Singh Nov 26 '18 at 2:02
1

Here is a simpler alternative solution that does not require installing the proprietary NVIDIA drivers.

  1. Login into recovery mode.

  2. Disable nouveau during the boot process.

    nano /etc/default/grub
    

    Change the line:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    

    To:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash modprobe.blacklist=nouveau"
    

    If you are not famaliar with nano, after editing the file, type CtrlX, Y, Enter to save the changes.

    (Nouveau will automatically be reloaded when Xorg starts, so you don't need NVIDIA proprietary drivers to be installed).

  3. Use Xorg on the GDM login screen instead of Wayland. (This is optional, but I recommend it).

    nano /etc/gdm3/custom.conf
    

    Change the line:

    #WaylandEnable=false
    

    To (un-commented):

    WaylandEnable = false
    

    If you are not famaliar with nano, after editing the file, type CtrlX, Y, Enter to save the changes.

  4. Update grub boot-loader.

    update-grub
    
  5. Reboot

References:

What does nomodeset do

How to blacklist kernel modules?

1
  • This is actually very useful because in recovery mode you may not have an internet connection so ubuntu-drivers autoinstall would not work out of the box. Using this method you can install the drivers through the UI after a reboot. – TimothyP May 19 '19 at 14:51
0

Took me a while to test out all these

  1. I tried installing 18.04, run update and smoothly everything before going to 18.10 and everything was fine. Problem only exist on brand new fresh installation

  2. As @Sean said, problem is with the driver. Way to solve it:

    • Reboot into safe-mode (hold Shift or Esc after passing BIOS phase). If you got into grub accidentally, just type in normal and it will take you to boot menu to select "Advance Options" -> "Recovery Mode"

    • In recovery mode, first you should enable networking. Then go into root command line and run ubuntu-drivers autoinstall and apt update && apt upgrade to update everything under network.

    • Type reboot to reboot to normal.

  3. Profit

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.