1

So I did check that my devices are registered both ethernet and wifi usb adapter lpci/lsusb they show up

when I check ifup or ifconfig I get no devices, ping fails

I am currently using i3-wm I tried to use the UI but I immediately get logged back out, not sure what's up with that, I have space, I experienced this when my disk space was empty.

But yeah right now I can't connect at all even with ethernet plugged in.

I say unusual dis-upgrade because this one was big and talked about installing new firmware and what not but as I mentioned the devices are found even the usb adapter...

I'm just trying stuff right now that I find on here

edit: it's fixed, I got lucky

Used these two links, I think I only needed the first one

https://ubuntuforums.org/showthread.php?t=2374838

DNS_PROBE_FINISHED_BAD_CONFIG error in Ubuntu 14.04

I did most of the lines in Hadaka's answer in first link, but I may have used the top answer in the second link, probably would have used the one with dpkg-reconfigure I've used that before

edit:

crap no it's not fixed, I at least have an IP again and can ping local network connected devices

edit: wth I don't understand this at all, now it works

I had to edit the /etc/resolv.conf and add 8.8.8.8 as a nameserver even though the file says "do not edit this file by hand" haha

ping 8.8.8.8 works but ping www.google.com doesn't

So first problem, had nothing, no interface, first attempt got me an ip at least vs. just down and then second got me to be able to connect outside eg. curl some link, now running update the package lists don't fail

  • You could try transferring the drivers for your wifi/ethernet and installing them in your machine. Then perhaps try a system upgrade. – Ganesh Kathiresan Oct 20 '18 at 5:13
  • Okay I just tried some systemctl network commands that failed saying "unknown interface" which I don't understand if they're visible through lsusb/lspci – it_is_written Oct 20 '18 at 5:18
  • Since we are unsure of the problem, I would suggest you look at the ethernet device from your manufactures website, then download the driver and transfer the same. BTW is that why you are trying a systemctl? – Ganesh Kathiresan Oct 20 '18 at 5:49
  • I got it working, but this update is nuts, dist-upgrade, never seen one like this where it asks you stuff like "bluetooth config, keep original?" sshd config, keep original? etc... idk probably should not have done this on a local server oh well – it_is_written Oct 20 '18 at 5:57
  • Oh great, good to know it's fine now. Please do drop an answer as it might help someone in the future. – Ganesh Kathiresan Oct 20 '18 at 6:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.