14

I asked this a year ago, with the new (awful) upgrade 18.04 upgrade, the fix got removed and reapplying it doesn't work.

I have a laptop, and while typing, my palm touches the touchpad, which makes the mouse move, close tabs by itself, delete words, open programs, and all other actions.

I want to disable it while typing, same way Windows automatically does it.

This is the previous question, the accepted answer worked for me in 16.04, but no longer works anymore. How do I disable the touchpad while typing?

Note that running the command mentioned in the accepted answer gives this:

Input:

sudo apt install xserver-xorg-input-libinput

Output:

xserver-xorg-input-libinput is already the newest version (0.27.1-1).
The following packages were automatically installed and are no longer required:
  libgnome-keyring-common libgnome-keyring0 libnih-dbus1
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Yes, I restarted my laptop.

4
  • Have you tried it from gnome tweaks? – UnKNOWn Oct 19 '18 at 22:11
  • You could try using syndaemon, as this answer describes. – earthmeLon Oct 19 '18 at 23:09
  • @earthmeLon Already tried that, doesn't work well. The one in 16.04 was working perfectly. – MichaelX Oct 19 '18 at 23:15
  • @PRATAP I've only used gnome tweaks once for a skin or something, do you know if it has an option for this? – MichaelX Oct 19 '18 at 23:17
15

I did it this way:

sudo apt remove xserver-xorg-input-synaptics
sudo apt install xserver-xorg-input-libinput
sudo reboot

On my machine I had both of them, so synaptics was default, deleting it helped me. Do not forget to reboot.

10
  • 1
    This worked for me (Lenovo X1 Carbon running Ubuntu 18.04 LTS). – ilmarinen Jan 18 '20 at 11:03
  • 2
    I ran into this in 19.10 after installing gnome, kubuntu, and a handful of other desktop environments I was experimenting with. Worked prior and didn't work again until I did the above. – mlissner Jan 23 '20 at 7:50
  • 1
    Works for me as well (Latitude 7390). Been playing around with different desktop environments lately. – Degraw Jan 27 '20 at 14:29
  • It worked for me. Some nuissance: first time I rebooted I could not see the box for typing the password, although typing it and hitting enter worked, and next time I rebooted everything was fine. – Lucas Mar 30 '20 at 17:48
  • 1
    @Lucas you can have "Tab on click" with libinput. Just go to "Mouse & Touchpad" settings. – Vadym K Apr 3 '20 at 10:17
4

Assuming your system is using libinput, not synaptics, here is the correction. Copy the following place in /etc/X11/xorg.conf.d/90-libinput.conf. Must log out to trigger a re-load of X11.

The change that affects the touchpad while typing is in the second to last line. In my case, I have some boiler plate that channels all of the action to the libinput driver, that may not be strictly necessary. HOwever, I'm certain that the last stanza is your magic bullet.

# Match on all types of devices but tablet devices and joysticks
Section "InputClass"
        Identifier "libinput pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "MyTouchpad"
        MatchIsTouchpad "on"
        Driver "libinput"
        Option "Tapping" "on"
        Option "DisableWhileTyping" "on"
EndSection
4
  • Thanks, this was the only solution that worked with my Alienware m15 r2 – manuel saraiva Apr 27 '20 at 16:20
  • I did a fresh install of Ubuntu 20.04 on a brand new laptop and learned that some desktops have this as a setting/correction. It appears Gnome desktop has a fix for tapping and disable while typing. However, I installed my favorite XFCE4 and it does not have a built-in fix and the X11 config change was still necessary. – pauljohn32 Apr 28 '20 at 20:48
  • 1
    This worked on my Xubuntu 20.04 and thankfully without installing any other software. I just had to create the /etc/X11/xorg.conf.d/ folder. Thanks! – user1252280 May 1 '20 at 15:43
  • Works like a charm on Ubuntu 20.10, thanks so much! – Nicholas Stommel Jan 18 at 6:23
4

Install gnome-tweaks

sudo apt install gnome-tweaks

and open it.

Under the tab Keyboard & Mouse you will find in the main window under Touchpad the switch Disable While Typing.

enter image description here

7
  • 5
    Doesn't work. What theme are you using? – MichaelX Oct 21 '18 at 15:48
  • I'm using a MacOS theme..However, opening gnome-tweaks & should display this menu. – abu_bua Oct 21 '18 at 15:58
  • 4
    The menu is displayed, selecting that option does not fix the problem. – MichaelX Oct 21 '18 at 16:02
  • 4
    Restarted the computer, it simply doesn't work. – MichaelX Oct 23 '18 at 1:33
  • 1
    This does not work for me on 18.10 either. – CPBL Jan 31 '19 at 14:52
1

Install Touchpad Indicator GNOME extension. Perfect.

https://extensions.gnome.org/extension/131/touchpad-indicator/

Switch the touchpad, trackpoint, fingertouch, touchscreen or a pen device on and off easily from the top panel. Optionally, automatically disable some or all devices when a mouse is plugged in and re-enable them when unplugged.

3
  • 1
    I tried that before, it doesn't offer what I'm looking for. – MichaelX Oct 21 '18 at 15:49
  • This doesnt' work in 18.04 – chovy Oct 2 '19 at 17:56
  • @chovy I believe that touchpad-indicator v2.2.1 in the Ubuntu repos does work though. – heynnema Oct 2 '19 at 19:01
1

I tried to many ways that did not work. Finally founded with this link below: https://help.ubuntu.com/community/SynapticsTouchpad

Type: xinput list Find your touchpad ID. For example it is "7"

Type: xinput --watch-props 7

Find "Palm detection" and "Palm Dimension" lines. There will be a number in parentheses near these lines. For example Palm Detection=(400) Palm Dimension=401

Open a new tab or New window

Type: xinput --set-prop 7 "400" 1 Type: xinput --set-prop 7 "401" 1, 100 After change of these settings you must see the changes with the previous tab like Property 'Synaptics Palm Dimensions' changed. For palm dimension you can find best for fits with you.

1

No extra package required to disable, do below

  1. Go to settings
  2. Devices
  3. Mouse & Touchpad
  4. In Touchpad toggle the button to off, see below picture enter image description here
0

I found what worked for me on Ubuntu 18.04. It was to reinstall xserver-xorg. I'm not sure about consequences so do it at your own risk MIGHT BREAK SOMETHING

sudo apt-get remove xserver-xorg
sudo apt-get install xserver-xorg
sudo dpkg-reconfigure xserver-xorg
apt-get install ubuntu-desktop  # It apparently deleted this package also

Someone at the same forum advised to remove xserver-xorg and its configs (I didn't need to do this)

sudo apt-get remove --purge xserver-xorg

Also what helped was palm rejection from Erdem KAYA answer. Other methods like gnome-tweaks or touchpad-indicator didn't work for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.