0

How do i add/mount my exsisting NAS drive (WD,MybookLive) so that i can add the folder to my plex server?

As i understand it (and this is day1 of me using Linix)

i have to add a line in fstab to mount the drive.

$ sudo gedit /etc/fstab

so i have added the following line:

//192.168.0.100/Public/videos/ /media/Plex cifs guest 0 0

I have three shares on my NAS,a public share called "Public",in there i have several folders but one called videos has... all the video files.

Public doesn't need an account/password but i have created a user called guest with no password and access to Public.

to test the mount i type

$ sudo mount -a

which gives the response:

mount error(22): Invalid argument Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

i can check my log, which states:

Oct 19 22:33:28 Jon-Server kernel: [ 3084.106615] No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.

so from what i understand, i have to do two things, maybe? one is specify the version of cifs

the other is to add in a line about the language/locale to use,

but i don't know how to parse that into one line or what i should even do now.

Thanks

  • You have come a long way in one day ;-) And mount messages are notoriously hard to figure out. Do you have cifs-utils installed? – Jos Oct 19 '18 at 22:00
  • yeah got that installed. – Jonathan Crook Oct 19 '18 at 22:02
  • Try removing the / at the end of //192.168.0.100/Public/videos/. – Jos Oct 19 '18 at 22:05
  • To specify the version, just add the option vers=1.0 to your options as guest,vers=1.0 – John Anderson Oct 19 '18 at 22:10
  • How do you know where the commers go? – Jonathan Crook Oct 19 '18 at 22:13
1

Finally with the post and comments above I could figure it out (MyBookLive connection, Ubuntu 18.04) The bit that helped was the SMB version (vers=1.0). For the sake of clarity:

//192.168.1.55/Videos /mnt/wdvideos cifs guest,vers=1.0 0 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.