I am trying to connect to a network printer that is a Toshiba e-Studio3505AC. At first I tried doing it through System Settings > Printers > Add > Network Printer > Find Network Printer. I entered the host address but wasn't sure what to select for Connection. Based on what I was able to find online, it seems that it is supposed to be one of the LPD/LPR queue options; but which one isn't clear. Based on other things I found online, I assumed it was LPD/LPR queue ''. Clicked Forward. When using Select printer from database, I select Toshiba (recommended) then click Forward. I look though the list and it isn't there. When using Search for a printer driver to download, it just finds Toshiba e-Studio350. So I figured I needed the PPD.

I tried to get the PPD by going to the support page. I downloaded linux.tar (which is not the PPD as far as I can tell) and then tried to follow the instructions in the installation guide.

Here are the two issues.

  1. The shell script wants me to restart my lpd. However, I am having trouble finding directions on how to do that. I can find a lot about lpd including the manpage, discussions of what it is, etc. but nothing about how to restart it.
  2. The installation guide says the linux users still need to add the printer via the OS's printer management tool. I am assuming that is what I used in my earlier attempts. When I do that, there is no change in what happens.
  • facing exactly same issue.. did you find a solution? – rok Aug 25 '20 at 10:11
  • @rok Unfortunately, no. I never got this issue resolved. The computer I was trying to connect was a dual-boot with Windows 7 so I eventually ended up just saving to a common drive, booting into Windows, and printing from there. Not at all convenient but better than no being able to print at all. – Andrew Shum Feb 21 at 2:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.