3

Trying to install the Brave web browser, I ultimately arrive at the error, "Unable to locate package brave-browser". How should I proceed?

Here is my LXTerminal output:

username@username-Latitude-D620:~$ curl https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key add -
[sudo] password for username: 

Command 'curl' not found, but can be installed with:

sudo apt install curl

Sorry, try again.
[sudo] password for username: 
Sorry, try again.
[sudo] password for username: 
sudo: 3 incorrect password attempts
username@username-Latitude-D620:~$ sudo apt install curl
[sudo] password for username: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  alsa-base cpp-5 evolution-data-server-online-accounts gksu gnupg-agent
  gtk3-engines-unico gvfs-bin ibus-mozc libaccounts-qt5-1 libavfilter-ffmpeg5
  libavresample-ffmpeg2 libboost-filesystem1.58.0 libboost-filesystem1.65.1
  libboost-system1.58.0 libcapnp-0.5.3 libcapnp-0.6.1 libcdio-cdda1
  libcdio-paranoia1 libcdio13 libchromaprint0 libestools2.4 libfcitx-qt0
  libgcr-3-common libgksu2-0 libglu1-mesa libgmime-2.6-0 libgnome-desktop-3-12
  libgnome2-0 libgnome2-bin libgrilo-0.2-1 libgtkglext1 libgtop-2.0-10
  libgweather-3-6 libido3-0.1-0 libisl15 libjasper1 libllvm3.8 libllvm4.0
  libllvm5.0 libmimic0 libmirclient9 libmircommon5 libmircommon7 libmircore1
  libmirprotobuf3 libmpfr4 libnm-gtk-common libopencv-calib3d2.4v5
  libopencv-contrib2.4v5 libopencv-core2.4v5 libopencv-features2d2.4v5
  libopencv-flann2.4v5 libopencv-highgui2.4v5 libopencv-imgproc2.4v5
  libopencv-legacy2.4v5 libopencv-ml2.4v5 libopencv-objdetect2.4v5
  libopencv-video2.4v5 libpoppler58 libprotobuf-lite10 libprotobuf-lite9v5
  libprotobuf9v5 libqt5opengl5 libqt5sql5 libqt5sql5-sqlite libqt5xml5
  libquvi-scripts libquvi7 librhythmbox-core9 libsignon-extension1
  libsignon-glib1 libsignon-plugins-common1 libsignon-qt5-1 libsodium18
  libsrtp0 libtbb2 libvte-common libvte9 libwebpdemux1
  libwebrtc-audio-processing-0 libwildmidi1 libxfont1 linux-headers-4.4.0-101
  linux-headers-4.4.0-101-generic linux-headers-4.4.0-112
  linux-headers-4.4.0-112-generic linux-headers-4.4.0-21
  linux-headers-4.4.0-21-generic linux-headers-4.4.0-93
  linux-headers-4.4.0-93-generic linux-headers-4.4.0-96
  linux-headers-4.4.0-96-generic linux-headers-4.4.0-97
  linux-headers-4.4.0-97-generic linux-image-4.4.0-101-generic
  linux-image-4.4.0-112-generic linux-image-4.4.0-21-generic
  linux-image-4.4.0-93-generic linux-image-4.4.0-96-generic
  linux-image-4.4.0-97-generic linux-image-extra-4.4.0-101-generic
  linux-image-extra-4.4.0-112-generic linux-image-extra-4.4.0-21-generic
  linux-image-extra-4.4.0-93-generic linux-image-extra-4.4.0-96-generic
  linux-image-extra-4.4.0-97-generic linux-sound-base lubuntu-artwork-16-04
  python-appindicator signon-plugin-password signon-ui signon-ui-service
  signon-ui-x11 signond x11-apps x11-session-utils xchat-gnome-common xinit
  xorg
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libcurl4
The following packages will be REMOVED:
  libcurl3
The following NEW packages will be installed:
  curl libcurl4
0 upgraded, 2 newly installed, 1 to remove and 0 not upgraded.
Need to get 400 kB of archives.
After this operation, 391 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://us.archive.ubuntu.com/ubuntu bionic-updates/main i386 libcurl4 i386 7.58.0-2ubuntu3.3 [238 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu bionic-updates/main i386 curl i386 7.58.0-2ubuntu3.3 [162 kB]
Fetched 400 kB in 1s (791 kB/s)
(Reading database ... 370863 files and directories currently installed.)
Removing libcurl3:i386 (7.58.0-2ubuntu2) ...
Selecting previously unselected package libcurl4:i386.
(Reading database ... 370857 files and directories currently installed.)
Preparing to unpack .../libcurl4_7.58.0-2ubuntu3.3_i386.deb ...
Unpacking libcurl4:i386 (7.58.0-2ubuntu3.3) ...
Selecting previously unselected package curl.
Preparing to unpack .../curl_7.58.0-2ubuntu3.3_i386.deb ...
Unpacking curl (7.58.0-2ubuntu3.3) ...
Setting up libcurl4:i386 (7.58.0-2ubuntu3.3) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for man-db (2.8.3-2) ...
Setting up curl (7.58.0-2ubuntu3.3) ...
username@username-Latitude-D620:~$ curl https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key add -
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  4715  100  4715    0     0   8946      0 --:--:-- --:--:-- --:--:--  8929
OK
username@username-Latitude-D620:~$ 
username@username-Latitude-D620:~$ echo "deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ `lsb_release -sc` main" | sudo tee -a /etc/apt/sources.list.d/brave-browser-release-`lsb_release -sc`.list
deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ bionic main
username@username-Latitude-D620:~$ 
username@username-Latitude-D620:~$ sudo apt update
Hit:1 http://us.archive.ubuntu.com/ubuntu bionic InRelease
Get:2 http://us.archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]   
Get:3 http://us.archive.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]  
Get:4 https://brave-browser-apt-release.s3.brave.com bionic InRelease [2,825 B]
Get:5 https://brave-browser-apt-release.s3.brave.com bionic/main amd64 Packages [1,521 B]
Fetched 176 kB in 2s (114 kB/s)       
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.
username@username-Latitude-D620:~$ 
username@username-Latitude-D620:~$ sudo apt install brave-browser
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package brave-browser
username@username-Latitude-D620:~$ curl https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key add -
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  4715  100  4715    0     0   6371      0 --:--:-- --:--:-- --:--:--  6363
OK
username@username-Latitude-D620:~$ echo "deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ `lsb_release -sc` main" | sudo tee -a /etc/apt/sources.list.d/brave-browser-release-`lsb_release -sc`.list
deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ bionic main
username@username-Latitude-D620:~$ sudo apt update
Hit:1 http://us.archive.ubuntu.com/ubuntu bionic InRelease
Get:2 http://us.archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]                                             
Hit:3 https://brave-browser-apt-release.s3.brave.com bionic InRelease                                                     
Get:4 http://us.archive.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]                                             
Fetched 172 kB in 1s (162 kB/s)                                
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
W: Target DEP-11 (main/dep11/Components-i386.yml) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
W: Target DEP-11 (main/dep11/Components-all.yml) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
W: Target DEP-11-icons-small (main/dep11/icons-48x48.tar) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
W: Target CNF (main/cnf/Commands-i386) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
W: Target CNF (main/cnf/Commands-all) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
W: Target DEP-11 (main/dep11/Components-i386.yml) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
W: Target DEP-11 (main/dep11/Components-all.yml) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
W: Target DEP-11-icons-small (main/dep11/icons-48x48.tar) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
W: Target CNF (main/cnf/Commands-i386) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
W: Target CNF (main/cnf/Commands-all) is configured multiple times in /etc/apt/sources.list.d/brave-browser-release-bionic.list:1 and /etc/apt/sources.list.d/brave-browser-release-bionic.list:2
username@username-Latitude-D620:~$ sudo apt install brave-browser
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package brave-browser
username@username-Latitude-D620:~$ 

It may be worth noting that I had errors upgrading from lubuntu 16:

  1. Could not install 'doc-base': installed doc-base package post-installation script subprocess returned error exit status 10

  2. at the end of the upgrade, "Could not install the upgrades": The upgrade has aborted. Your system could be in an unusable state. A recovery will run now (dpkg -configure -a).

However, despite #2, the upgrade seemed to be successful, and fixed a splash page visual error: Before upgrading to lubuntu 18 LTS I installed upgrades to lubuntu 16 LTS after not using the laptop for about a year; it caused the 5-dots loading screen's dots graphic to remain after logging in. Restarting the computer after this supposedly-failed upgrade to 18, this problem was resolved.

5
  • About curl part you can rewrite the install command to use wget. The command will be wget https://brave-browser-apt-release.s3.brave.com/brave-core.asc -O - | | sudo apt-key add -.
    – N0rbert
    Oct 19, 2018 at 20:07
  • Also it seems that you have not enabled universe repository. Do it with askubuntu.com/questions/148638/… .
    – N0rbert
    Oct 19, 2018 at 20:09
  • @N0rbert, see screenshot at this additional question; it appears the universe reporsitory is enabled: askubuntu.com/questions/1085366/… Oct 19, 2018 at 20:48
  • Please fix all issues and after then, update your question with current error output of apt-get update and apt-get upgrade.
    – N0rbert
    Oct 19, 2018 at 20:50
  • Performing the suggested autoremove would, at a minimum, reduce the amount of output you get. Do you really need 8 old kernels? Aug 5, 2019 at 10:42

2 Answers 2

1

I got the same message. You can install it as a snap program...

sudo snap install brave

Do you get an error message...sudo: snap: command not found

You have to install snapd not snap:

sudo apt-get install snapd

Then repeat the sudo snap install brave command

0

You can checkout the install page here.

Specifically:

sudo apt install apt-transport-https curl gnupg

curl -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -

echo "deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main" | sudo tee /etc/apt/sources.list.d/brave-browser-release.list

sudo apt update

sudo apt install brave-browser

Not the answer you're looking for? Browse other questions tagged .